Wi-Fi calling issue

  • 1
  • Question
  • Updated 3 months ago
Good evening all,

I've attempted to ring Koodo's customer service on this before posting, but with no resulting resolution. I initially had a problem enabling Wi-Fi Calling from my home network and had to call for them to manually enable it on my account. They did so while also enabling VoLTE which, not amusingly, was throwing the same "contact Koodo to enable <feature>" error.

I'm presently using an iPhone 7 Plus running iOS 11.4.1 Public beta 1. Whilst connected to my home access point, an Actiontec R3000 on Bell Aliant FibreOP, Wi-Fi Calling does not work on the Koodo network.

That said, my mother also uses an iPhone, a 6S connected on the Bell network. I enabled Wi-Fi calling on her device yesterday and, much to my dismay, it works properly.

I do know that Wi-Fi calling works on my phone on Koodo in different locations (I've tested at the supermarket and by tethering my iPhone to my Samsung phone), but it does not want to work here. 

Has anyone experienced this problem after enabling Wi-Fi calling? I've verified that my phone should be forwarding the correct ports on-demand (uPNP is enabled on the router) and that the feature works with different carriers. Is there a difference between Wi-Fi Calling on Koodo and Wi-Fi Calling on Bell Mobility, port-wise?

Let me know. Thanks!
Photo of Dee

Dee

  • 130 Points 100 badge 2x thumb
  • confused

Posted 3 months ago

  • 1
Photo of Dennis

Dennis, Mobile Master

  • 201,104 Points 100k badge 2x thumb
Does your mom's phone work with wifi calling on your home wifi?
Photo of Dee

Dee

  • 130 Points 100 badge 2x thumb
Sure does, Dennis. The expected "Wi-Fi" text appears beside the carrier name and the phone is able to make and receive calls while connected to the same Wi-Fi as my iPhone.
Photo of Dennis

Dennis, Mobile Master

  • 201,104 Points 100k badge 2x thumb
Ok then your wifi is not the issue.  Your account is also not the issue since you are able to make wifi calls on other wifi connections.  

The only remaining that is out of the ordinary is your beta iOS version?
Photo of Dee

Dee

  • 130 Points 100 badge 2x thumb
I'm floored. Any calls made from the iPhone on Bell's network while connected to Wi-Fi and the "Wi-Fi" text is showing up now do not connect. It worked yesterday evening. Disconnecting from Wi-Fi resolves the issue. Connected said phone back to Wi-Fi and, lo and behold, Wi-Fi calling no longer works on the good phone.

I'll have to take it up with my ISP now.
(Edited)
Photo of Dinh

Dinh, Mobile Master

  • 45,986 Points 20k badge 2x thumb
@Dee: you are running a Beta version of iOS. Have you tried to use it on a official released one? A beta version might not have a proper carrier update. It could be the reason why wifi-calling didn't work.
Photo of Dee

Dee

  • 130 Points 100 badge 2x thumb
As of the time Wi-Fi Calling was released to Koodo postpaid customers, I was in fact running the current public release version of iOS which had the appropriate carrier update. I believe I've isolated the problem to either my specific location or to my ISP.
Photo of Dinh

Dinh, Mobile Master

  • 45,986 Points 20k badge 2x thumb
Koodo Wi-FI Calling sometimes turned on only when the cellular signal is weak. On my iphone,  if the cellular signal was strong, wifi-calling didn't kick in.

I would suggest you turn ON the Airplane mode, and turn ON Wifi and see if that helps. On my iPhone that would enable the phone to connect to wifi-calling. Also make sure you enable it properly (Settings --> phone --> wifi Calling ON).
(Edited)
Photo of Dee

Dee

  • 130 Points 100 badge 2x thumb
Hey Dinh,

Unfortunately, even with Wi-Fi turned on while Airplane Mode is active, Wi-Fi calling did not kick in. I've also been unable to re-establish a Wi-Fi Calling connection with my mother's iPhone since just a few moments ago. I therefore believe the problem is not specifically with Koodo but with my ISP or router configuration.
(Edited)
Photo of Mats

Mats

  • 24,654 Points 20k badge 2x thumb
Are you sure you have the latest carrier update?

Settings/General/About
Once you click on "About" a carrier update will pop up if there is one.

I also kept getting the contact Koodo to enable error until I got the latest carrier update.
Photo of Dinh

Dinh, Mobile Master

  • 45,986 Points 20k badge 2x thumb
@Dee: if possible, can you test your phone with another wifi network. Have you tried to bring it to apple store and check?
Photo of MoFromTo2018

MoFromTo2018

  • 2,330 Points 2k badge 2x thumb
Do a hard restart on your iPhone. Also network reset can work.
(Edited)
Photo of You-Do-Not-Know-Who

You-Do-Not-Know-Who

  • 110 Points 100 badge 2x thumb
https://www.telus.com/en/on/support/article/wifi-calling-faq 
In rare cases, your internet service provider (ISP) may affect your abilility to connect. Please contact us if you are not able to connect through the following ISPs :
  • Bell Aliant
Good luck getting help from Koodo about it.

Try changing the DNS on your iPhone Wi-Fi to 1.1.1.1 and 1.0.0.1.