Why is my phone not receiving text messages?

  • 2
  • Question
  • Updated 5 years ago
  • Answered
  • (Edited)
I have unlimited texting ..... But my phone isn't reviving text messages out of my house... Only when I get home all the messages appear!!...it's like you need wifi....help please ...:(
Photo of Francheska Ruiz

Francheska Ruiz

  • 362 Points 250 badge 2x thumb
  • sad, confused, frustrated

Posted 5 years ago

  • 2
Photo of PZABOY

PZABOY

  • 5,142 Points 5k badge 2x thumb
Have you tried resting your phone?(battery pull depending on device) as well make sure 3G is enabled :)
Photo of Francheska Ruiz

Francheska Ruiz

  • 362 Points 250 badge 2x thumb
Yes I have tried everything :/...
Photo of Paul Deschamps

Paul Deschamps, Mobile Master

  • 203,908 Points 100k badge 2x thumb
what phone do you have?
Photo of PZABOY

PZABOY

  • 5,142 Points 5k badge 2x thumb
Well text messages don't use data unless they are iMessage or picture message. So being on or off wifi shouldn't affect that. If your on an iPhone go to settings and make sure cellular data is on as well if your using iMessage.
Photo of PZABOY

PZABOY

  • 5,142 Points 5k badge 2x thumb
Settings>general>cellular>cellular data (on)
Photo of Paul Deschamps

Paul Deschamps, Mobile Master

  • 203,908 Points 100k badge 2x thumb
seen you posted twice here so thinking you don't know but you can edit or add to posts by clicking on the post you did. Then in the top corner of that post it will give you an option to edit or delete your post. Click on edit and you can change or add to that post instead of making another complete post.
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
Samsung Galaxy Ace???
Photo of Francheska Ruiz

Francheska Ruiz

  • 362 Points 250 badge 2x thumb
No iPhone 4...
Photo of Jorden

Jorden, Mobile Master

  • 33,404 Points 20k badge 2x thumb
It's probably because you have iMessage turned on which requires a data connection. Are the text bubbles blue? IF that's the case you need to go into settings, then choose Messages and turn iMessage off. Sometimes it can take a bit of time for Apple's servers to realize you do not have iMessage anymore but you should start receiving text messages (in green bubbles) over the cell network this way.

Make sure you do this when you are at home on your wifi if this all sounds right!
Photo of Francheska Ruiz

Francheska Ruiz

  • 362 Points 250 badge 2x thumb
OMG thanks!!! ^^ that helped alot!!!
Photo of Jorden

Jorden, Mobile Master

  • 33,404 Points 20k badge 2x thumb
No problem! While I was reading I realized it sounded like it was an iMessage issue. Glad it helped!
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
Make sure you star the answer that helped you. That way out gets pushed to top for others who have the same problem later. Glad you got it working.

This conversation is no longer open for comments or replies.