why is my new phone telling me when i dial out "not registered on network"?

  • 2
  • Question
  • Updated 2 years ago
  • Answered
Photo of Janelle Rousselle

Janelle Rousselle

  • 120 Points 100 badge 2x thumb

Posted 5 years ago

  • 2
Photo of Sophia

Sophia, Mobile Master

  • 141,558 Points 100k badge 2x thumb
Hi Janelle,

Could be a few reasons. If you got the phone from Koodo and if they set it up for you, all you probably need to do is switch off the phone for a few minutes, take out the SIM card, then put everything back and switch it back on.

Try that first, if it doesn't work, we can continue troubleshooting you :)

What phone is it?
Photo of Janelle Rousselle

Janelle Rousselle

  • 120 Points 100 badge 2x thumb
samsung galaxy ace.. someone told me we might not have towers around here for the new phones where i live?? i live in marathon ON.
Photo of Janelle Rousselle

Janelle Rousselle

  • 120 Points 100 badge 2x thumb
galaxy ace II x actually
Photo of Timo Tuokkola

Timo Tuokkola, Mobile Master

  • 140,062 Points 100k badge 2x thumb
Sorry to be the bearer of bad news, but none of the newer sim card based phones will work in Marathon. "Superior in the long run" you may be, but there is no HSPA coverage, so only older cdma phones like the Blackberry 8530 will work.
Photo of Jonathan

Jonathan

  • 816 Points 500 badge 2x thumb
Problem is that you're not "not registered on network" you have lost signal and the phone is not connecting to Koodo, solution is simple. Go to SETTINGS►WIRELESS & NETWORKS ►MOBILE NETWORKS ► and NETWORK OPERATORS, click on search for network ensure that on network mode 2G network is turn off and that its set on GSM/WCDMA auto or you can try what sophia said.
Photo of Janelle Rousselle

Janelle Rousselle

  • 120 Points 100 badge 2x thumb
i already tried what sophia told me and then just now what you said and still cant dial out it said i was registered on a network but think it was rogers. (not sure). I think i need a trouble shoot please i would like to keep my phone and not send it back!
Photo of Deborah Jackman

Deborah Jackman

  • 82 Points 75 badge 2x thumb
this just helped me!!! thank you!!
Photo of Sophia

Sophia, Mobile Master

  • 141,558 Points 100k badge 2x thumb
Ah Janelle, you could try to manually find the network... I'm not entirely sure where to find that on the Ace but go into settings, and it should probably be under Wireless and networks - Select Mobile networks - Select Network operators.
Then search and select Koodo when it pops up... does that help?
Photo of Janelle Rousselle

Janelle Rousselle

  • 120 Points 100 badge 2x thumb
I have to send it back that is all...there are no towers in my area that support the newer phones which sucks!!! i was just starting to like the phone!! thanks ev1 for your help tho :)