Why is my MMS not working?

  • 2
  • Question
  • Updated 3 years ago
  • Answered
Every time I receive a picture, I cannot download it and get a message that says:

"Message not downloaded. Generic Network failure"

I am also unable to send MMS. I have an HTC One M8. And I am connected to WIFI.

I've done some research and it seems like many HTC phones have this problem. Is there anyway to fix it?
Photo of Koloon

Koloon

  • 162 Points 100 badge 2x thumb

Posted 4 years ago

  • 2
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
Your network data must be enabled to send mms. Wifi won't work.
Photo of Koloon

Koloon

  • 162 Points 100 badge 2x thumb
O thank you it worked
Photo of Chris Petersens

Chris Petersens

  • 47,266 Points 20k badge 2x thumb
Just curious, did you disable data yourself on the phone?
Photo of LynneG

LynneG

  • 218 Points 100 badge 2x thumb
I have had this same problem and I haven't disabled anything. I only send photos via text message when I am connected to wifi as I do not have a data plan. Sometimes it works and most times I get the same response "generic network failure". I'll try and find the 'network data' in my HTC phone and see if that is disabled
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
Even though your phone is connected to wifi, your device will still attempt to make a data connection to Koodo but only to send your picture message. If you have data turned off, you won't be able to send the message. Data must be enabled.
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
Settings... Wireless and networks... Mobile network
Make sure data is enabled
Also make sure the back is properly installed as the antenna is back there.

The fact you're using the one v may be part of your problems. It's an older device.
Photo of LynneG

LynneG

  • 218 Points 100 badge 2x thumb
My phone has really been acting out recently and I'm getting a little fed up with it - time for a new phone I think :)

I've looked at the Mobile Network Settings and I have the following options:

Data Roaming

Data roaming sound

both are unchecked
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
So those are as they should be.

It might also say Packet Data enabled
Photo of LynneG

LynneG

  • 218 Points 100 badge 2x thumb
Chad I really appreciate your help -- i think the next stop is either a koodo desk or future shop where i got the phone and see if either they can fix the issue or look at something new :)
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
No problem, there is a lot of New out there since you got your One V. Good luck and if you do G et a new device, let us know so we can share in phone Geek pride.
Photo of LynneG

LynneG

  • 218 Points 100 badge 2x thumb
THANKFUL for awesome help

This conversation is no longer open for comments or replies.