Why is my iphone 5s taking up to 20 minutes to receive imessages

  • 2
  • Question
  • Updated 5 years ago
  • Answered
Hi there,
I upgraded to a 5s a few weeks ago because I was having this SAME problem on my 4 and I thought getting a new phone would solve it:
Sometimes, it will take up to 20 minutes for my phone to receive an imessage. When it finally comes in, I can see that it was supposed to be delivered forever ago, but am only just receiving it. That is happening when I am sitting at home on wifi.
Additionally, I have noticed that I will not receive a text from someone on an iphone if I am not on wifi or data. I get bombarded with imessages that I was supposed to receive when I do connect. It's like it doesn't default to sending them as texts if not on wifi.
Any thoughts? Thanks in advance, this is getting frustrating!
Photo of Dani Rose Schlehahn

Dani Rose Schlehahn

  • 518 Points 500 badge 2x thumb

Posted 5 years ago

  • 2
Photo of Daniel Kim

Daniel Kim, Mobile Master

  • 34,736 Points 20k badge 2x thumb
You answered your own question! iMessage requires a data/wifi connection to receive/send messages. Turn iMessage off and you should be fine and have your friends send as SMS
Photo of Dani Rose Schlehahn

Dani Rose Schlehahn

  • 518 Points 500 badge 2x thumb
Hi, no that's not what I meant! I know iMessage requires data or wifi. When I am out and about without any, I will not receive any sort of message from any of my friends with iPhones. It should default to text message and I should receive it if I'm not on wifi. I don't receive it AT ALL until I'm home on wifi. Does that make sense?
Photo of Dani Rose Schlehahn

Dani Rose Schlehahn

  • 518 Points 500 badge 2x thumb
Thanks but I was hoping for an actual permanent solution.. It never used to do that. I really love to be able to use iMessage, I mean that's one of the main reasons I use iPhones haha.
Photo of Daniel Kim

Daniel Kim, Mobile Master

  • 34,736 Points 20k badge 2x thumb
Ok well you could keep data on but make sure none of your applications automatically use it and track your usage very carefully then that should do it. iMessage doesn't use much data. How much data do you have on your plan?
Photo of Dani Rose Schlehahn

Dani Rose Schlehahn

  • 518 Points 500 badge 2x thumb
Not enough to justify leaving it on.. 200MB. That disappears way too quickly. I just think this is stupid and should be able to be fixed some how, properly. Was hoping someone else would have similar issues so apple would come out with an update or something.
Photo of Zaphod Beeblebrox

Zaphod Beeblebrox

  • 50,808 Points 50k badge 2x thumb
That's exactly what the problem is. Apple came out with an update (iOS 7) and those that use iMessage were affected.

Maybe call Apple about this issue because there isn't much else anyone can do here...
Photo of Dani Rose Schlehahn

Dani Rose Schlehahn

  • 518 Points 500 badge 2x thumb
Kay thanks.
Photo of Dani Rose Schlehahn

Dani Rose Schlehahn

  • 518 Points 500 badge 2x thumb
Thanks for trying btw!
Photo of Ivan

Ivan, Mobile Master

  • 96,634 Points 50k badge 2x thumb
This is definitely an iMessage problem. But I don't think that it's on your end.

Yes, when you don't have an active data connection it's supposed to default to SMS and if you send a message, it will. The problem here is that when a friend attempts to send you an iMessage it doesn't seem to recognize that you're offline and the message hangs on the server until you reconnect.

My only recommendation that avoids you getting a data plan is to leave iMessage permanently off. Toggle it on only as needed.
Photo of Zaphod Beeblebrox

Zaphod Beeblebrox

  • 50,808 Points 50k badge 2x thumb
Maybe get in contact with Apple for this...
Photo of Dennis

Dennis, Mobile Master

  • 196,856 Points 100k badge 2x thumb
It is up to the sender to choose to send as SMS


Also your friends may be sending to your icloud email address and not to your phone number. If it is being sent to the email address then it may not convert to sms
Photo of Ivan

Ivan, Mobile Master

  • 96,634 Points 50k badge 2x thumb
Good point. I'm still not a fan of Apple defaulting to iMessage. I've had a few SMSs hijacked by an iPhone that I wasn't currently using but that was connected to a WiFi hotspot.
Photo of Dennis

Dennis, Mobile Master

  • 196,856 Points 100k badge 2x thumb
That's even a better point Ivan.

Make sure there is no other i-device on that has imessage activated (like an ipad or mac)
Photo of Dani Rose Schlehahn

Dani Rose Schlehahn

  • 518 Points 500 badge 2x thumb
Wow thanks guys. You had a really good point, I turned my email address off for sending and receiving so it's just my phone number. I really hope that works because that seems like an obvious fix, can't believe I didn't think of it! Here's hoping it does the trick. Really appreciate all your help! I'll reply back in a few days for an update.
Photo of Daniel Kim

Daniel Kim, Mobile Master

  • 34,736 Points 20k badge 2x thumb
:)
Photo of Dani Rose Schlehahn

Dani Rose Schlehahn

  • 518 Points 500 badge 2x thumb
Hey guys, just an update. Sadly I am still having the same problems receiving my messages as texts. I thought turning off my email as a recipient option would have fixed it but I was so lucky.
Any new ideas?? Thanks :)
Photo of Dennis

Dennis, Mobile Master

  • 196,816 Points 100k badge 2x thumb
At this point I say bring it to an Apple Store and get help at the Genius Bar
Photo of Ivan

Ivan, Mobile Master

  • 96,634 Points 50k badge 2x thumb
I second Dennis' response. You've had this issue on multiple Apple devices now.

Make sure you make an appointment prior to showing up at the Apple Store.
Photo of Dennis

Dennis, Mobile Master

  • 196,816 Points 100k badge 2x thumb
You will need an Apple ID to make an appointment too
Photo of Dani Rose Schlehahn

Dani Rose Schlehahn

  • 518 Points 500 badge 2x thumb
Kay thanks guys.
Photo of Ivan

Ivan, Mobile Master

  • 96,634 Points 50k badge 2x thumb
Actually, I have something else you can try (if you haven't already). First, make sure that iMessage is turned off (Settings > Messages):



Then, reset your network settings (Settings > General > Reset):



Your phone will restart (you'll lose any WiFi passwords). Then, go back to the Messages settings from step one and re-activate iMessage.
Photo of Dani Rose Schlehahn

Dani Rose Schlehahn

  • 518 Points 500 badge 2x thumb
Actually I did try that! Although my phone did not restart..
Photo of Dennis

Dennis, Mobile Master

  • 196,856 Points 100k badge 2x thumb
You can also try doing a Hard Reset:

Press and hold the Home button and the Sleep button at the same time (at least ten seconds), until the Apple logo appears. Then release.

This conversation is no longer open for comments or replies.