Why won't my unlocked phone connect to Koodo?

  • 1
  • Question
  • Updated 7 months ago
  • Answered
  • (Edited)
I recently decided to try an inexpensive dual sim Chinese made phone to see if it work with Koodo.  All indications suggest it should (except for LTE data).

I ran it through Frequency Check web site and it seems to have the correct frequencies (850 / 1900 on GSM)

Here are the details:


I took the Koodo SIM from my Koodo phone and put it in this unlocked phone.  It detected it as a "Telus" SIM and correctly identifies my Koodo phone number.  When I search for cell signals it found Koodo, but always failed to connect.  INterestingly, when I put in a Fido SIM, I can connect with no issue.  

Any thoughts?

Keith R
Photo of Keith Richmond

Keith Richmond

  • 466 Points 250 badge 2x thumb
  • puzzled

Posted 1 year ago

  • 1
Photo of David

David, Mobile Master

  • 83,330 Points 50k badge 2x thumb
YUP! Fido has a 2G network, which is the second SIM slot default configuration. Try putting your Koodo SIM in the other slot.
Photo of Keith Richmond

Keith Richmond

  • 466 Points 250 badge 2x thumb
Thanks. I will give that a try. 

That being said, my Fido card also has odd behaviour.    It can connect to talk and text on the Edge network, and shows full bars.  As soon is the data shows 4G, the ability to talk and text is suddenly gone. 

<pause while I give it a try>

OK, for my Koodo SIM card, it seems that it does to work no matter which SIM slot I use.  The SIM settings show my Koodo number, and when I scan for cell service, Koodo 4G is an option, but it sits there saying "authenticating registration" for a while, then says "Can't connect to this network at the moment, Please try again later."  I tried the Koodo SIM in each SIM slot and in each case left the other slot empty. 

Is there something I am still missing?

Keith R

P.S.   Here is teh specs list:  

Model:HT3 PRO 
SIM Quantity:Dual SIM 
SIM Types:Micro SIM Card 
CPU Processor:Quad Core, 1.3GHz 
OS System:Android 5.1 
External Memory:Support Micro SD card up to 64GB (not included) 
Sensor:G-sensor, Light sensor 

Band (2G): GSM 850/900/1800/1900MHz 
Band (3G): WCDMA 900/2100MHz 
Band (4G): FDD-LTE 800/1800/2100/2600MHz 
Photo of David

David, Mobile Master

  • 83,290 Points 50k badge 2x thumb
No, on Fido the 2G network is still live, as indicated by Timo.
Photo of Keith Richmond

Keith Richmond

  • 466 Points 250 badge 2x thumb
Got it. 
Photo of titaniumtux


  • 12,892 Points 10k badge 2x thumb

Only Fido/Rogers have 2G, and it'll likely be phased out soon, just as Telus/Bell are phasing out CDMA. Maybe keep the unlocked 2G phone as a travel phone, but probably won't be useful long term in the Great White North.

Photo of Chris Holisky

Chris Holisky

  • 70 Points
You most likely have to (as I did) manually set the Access Point Name. Either call Koodo(ideally on a different phone than had the problem so you can follow their directions and test it while you're still talking with them) , check their website site for the info or use the info on the following link; http://www.androidcoliseum.com/2013/0...
Photo of Timo Tuokkola

Timo Tuokkola, Mobile Master

  • 136,992 Points 100k badge 2x thumb
1) APN settings ONLY affect data service. They have nothing whatsoever to do with voice or text.
2) as discussed above, the reason this particular phone did not work is that it did not sort the required frequencies to connect to koodo's 3G network.
3) this question is 8 months old. Please don't necro long dead threads; Especially ones that have long been answered.