Why is my 4G signal so weak?

  • 1
  • Question
  • Updated 2 years ago
  • Answered
On the nearest major road (10 m away) I get full bars. By the time I hit the bottom of my driveway, I'm down to 3 then I have 2 once I'm in the door of the ranch style home I live in. In the basement I get 1 bar, so trying to use my phone at all is pointless.

What can I do to improve the signal strength?
Photo of Sylvain G.

Sylvain G.

  • 80 Points 75 badge 2x thumb

Posted 2 years ago

  • 1
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
Basements are a terrible place to try to get a cell signal these days.

You can purchase a signal Booster like ones sold in bestbuy.ca from a. Company called Wilson. Other signal amplifiers may also be available elsewhere. Check the Internet for more options.
Photo of Sylvain G.

Sylvain G.

  • 80 Points 75 badge 2x thumb
My main concern is the 2 bars I'm getting on the main floor of the house. I'm close enough to downtown Ottawa that signal strength shouldn't be an issue.
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
Could be any number of factors

Distance from the tower
Trees
Older houses near you
Older house.
Height of your land.

A signal amplifier might get you to three bars on the ground level.
Photo of Paul Deschamps

Paul Deschamps, Mobile Master

  • 203,908 Points 100k badge 2x thumb
I only get 2-3 bars at all times where I live and never had any issues what so ever, never had a dropped call or any type of connection issues. Are your calls actually getting terminated mid call or not connecting or are you just worrying about the amount of bars your phone is presenting you with no actual connection issues?
(Edited)
Photo of rikkster

rikkster, Mobile Master

  • 68,420 Points 50k badge 2x thumb
You can try switching network modes. In some cases, switching to WCDMA Only will show a slight increase in signal strength. I’m not sure which Android device you have, but the path to network modes is similar. Go to: Settings > Mobile networks – tap Network mode and select WCDMA Only, (if listed). Do not reboot your phone. You should see a slight increase in signal strength.