Why does the Koodo website never work properly?

  • 2
  • Question
  • Updated 1 year ago
Anytime I ever try to do anything on the Koodo website there is so many problems.. It is so slow and nothing ever works 100%. So annoying. Right now I am looking into the iphone SE but whenever I click on a different colour or different storage size it just is a pop up with some error code text and doesnt do anything. So infruriating. 
Photo of bags

bags

  • 80 Points 75 badge 2x thumb
  • mad

Posted 1 year ago

  • 2
Photo of Bernard

Bernard, Official Rep

  • 75,642 Points 50k badge 2x thumb
Hmmmmm....very strange....everything seems to work as intended. At least when I check now. We also receive no reports about anything broken. Our tracking indicate a 99.9% uptime for the past 7 days. Do you mind posting a screenshot of what you are experiencing? I wonder if it has to do we browser compatibility.
Photo of Cory

Cory

  • 10,482 Points 10k badge 2x thumb
I just played around with all the SE options in both the Chrome browser on my phone, as well as my desktop. Everything worked normally. What browser and version are you trying it with?
(Edited)
Photo of titaniumtux

titaniumtux

  • 12,912 Points 10k badge 2x thumb

Only difficulty I've had with the Koodo website itself was when I did a web order for a phone and paid something upfront, had to do it from a desktop with IE11 browser (wouldn't process my credit card via my webkit browsers Chrome/Opera on my Koodo Moto X Play).

The forum, on the other hand, is another story. I can't log in on my smartphone, neither on my Moto X Play, nor my Moto Z Play, both from Koodo. No dice on mobile nor desktop user agent on Opera, Chrome, Good Old Browser or even Firefox.

(Edited)
Photo of Cory

Cory

  • 10,482 Points 10k badge 2x thumb
That's odd. I am replying to this from Chrome on my phone as we speak. I've never had an issue.
Photo of titaniumtux

titaniumtux

  • 12,912 Points 10k badge 2x thumb
Agreed. Seems strange that I can't log into the forum on any mobile device on any browser.
Photo of Bernard

Bernard, Official Rep

  • 75,642 Points 50k badge 2x thumb
What's happening? We haven't heard of that before.
Photo of Elyse Max

Elyse Max

  • 130 Points 100 badge 2x thumb
Every time I try and use the website it never works. For months I have been dealing with this. Called support and they said they were aware of the problem and were fixing it. Well they have not fixed it. Me and my husband have iPads and a home computer. Tried on all of them and you can login but other than that you can't do anything on self serve. It has blank screens or they don't load at all or it boots me out and I have to sign back in again. How is it that your website always has issues?? Very frustrating. I shouldn't have to call to ask to know about my data usage or about where my tab is at or to make any changes. Makes me want to switch providers.
Photo of Bernard

Bernard, Official Rep

  • 75,642 Points 50k badge 2x thumb
hmmmmm.....the last time I see you logged in, at least what we can see from our side, is about 2 years ago. The email that you used here is also not the email that we have registered for your account. Could yo send us a private message on Facebook and we can help change/fix things if needed.