Why can't I send a photo by text? Data is enabled. And I'm on wi-fi anyway....

  • 1
  • Question
  • Updated 2 months ago
  • Answered
Tried sending a photo by text for the first time today.  It failed.  Three times.  I am on a prepaid plan, I have a data booster and my data is always on, but I'm doing this from home where I have wi-fi.  I'm using a Samsung Galaxy S3 in Nova Scotia.  
Photo of Mark Young

Mark Young

  • 250 Points 250 badge 2x thumb

Posted 11 months ago

  • 1
Photo of Allan

Allan, Mobile Master

  • 56,726 Points 50k badge 2x thumb
Does your data work for other things?
Check under in your APN settings for APN type and see if it says "default, mms" or something similar. Also try turning off your wifi, leaving data on and trying to send it.

Note: MMS can only be sent over data, so a wifi connection makes no difference. 
(Edited)
Photo of Mark Young

Mark Young

  • 250 Points 250 badge 2x thumb
Turned wi-fi off.  Internet works fine.  Trying to text a picture -- it's just sitting there with the little wheel going round -- just like it did before for several minutes before it failed.
(Edited)
Photo of Allan

Allan, Mobile Master

  • 56,586 Points 50k badge 2x thumb
Check your APN Type to make sure mms is included. If not, add it yourself.
Photo of Mark Young

Mark Young

  • 250 Points 250 badge 2x thumb
APN type is now "default, mms" (without the quotes).  It's been twelve minutes of the wheel going round.  I deleted the earlier attempt (after 18 minutes).  Still waiting....
Photo of Mark Young

Mark Young

  • 250 Points 250 badge 2x thumb
Rebooted the machine to see if it'd help.  It didn't.

Access point settings:
  • Name: KOODO
  • APN: sp.koodo.com
  • Proxy: not set
  • Port: not set
  • Username: not set
  • Password: not set
  • Server: not set
  • MMSC: http://aliasdirect.net/proxy/koodo/
  • MMS proxy: 79.49.0.18
  • MMS port: 80
  • MCC: 302
  • MNC: 220
  • Authentication type: not set
  • APN type: default, mms
  • (disabled) APN protocol: IPv4
  • (disabled) APN roaming protocol: IPv4
  • (disabled) Enable/disable APN: APN enabled
  • Bearer: unspecified
  • Mobile virtual network operator type: none
  • (disabled) Mobile virtual network operator value: not set
Proxy and Port had been set the same as MMS-proxy and -port, but I deleted those values because another community post said they should not be set.
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,968 Points 100k badge 2x thumb
At the end of the MMSC URL in your apn, add "mmsc" without the quotes.
Photo of Mark Young

Mark Young

  • 250 Points 250 badge 2x thumb
Sorry, it was already there.  I had my phone in portrait and it showed just to the koodo/, which looked like a fine ending.  But when I turn my phone to landscape I see that it is, in fact ...koodo/mmsc
Photo of Mark Young

Mark Young

  • 250 Points 250 badge 2x thumb
APN type was not set.  I've changed it to default,mms.  Trying again.  Still getting the little wheel....
Photo of Mark Young

Mark Young

  • 250 Points 250 badge 2x thumb
PS:  before I started messing with it, I was able to attach a profile picture to a text (tho' the text didn't get sent).  Now it tells me that format isn't supported.  (I'm just sitting here watching the wheels go round and round....)
Photo of Mark Young

Mark Young

  • 250 Points 250 badge 2x thumb
OK, installed Chomp and tried it out.  It sends the message.  Of course my son can't view the message using Messaging....  So does that mean it's a problem with Messaging?  On all our phones?
Photo of Mark Young

Mark Young

  • 250 Points 250 badge 2x thumb
PS: it sends the photo -- or claims to have, anyway....
Photo of Mark Young

Mark Young

  • 250 Points 250 badge 2x thumb
PPS: and, of course, my younger son is using Messages on an iPhone, not Messaging on an Android....
Photo of Dennis

Dennis, Mobile Master

  • 187,512 Points 100k badge 2x thumb
Is his data enabled?  It wont work on wifi.  Cellular data must be on
Photo of Mark Young

Mark Young

  • 250 Points 250 badge 2x thumb
Latest update -- chomp says it sent the message with photo, but no message arrived (chomp on both ends).  I changed the settings to ask for a delivery report, and the photo is now sitting there in a "pending" state.  So it looks like it's not just Messaging that's the problem.
Photo of Mark Young

Mark Young

  • 250 Points 250 badge 2x thumb
More information.  My elder son has the same kind of phone and plan; my younger son has the same kind of plan but a different phone (iPhone 5s).  Neither of them can send photos, either.
Photo of Goran

Goran, Mobile Master

  • 90,654 Points 50k badge 2x thumb
Check settings, messages, check that mms is turned on. And yes whatsapp works strictly with data, WiFi or cellular, so it won't have the same issje.
Photo of Mark Young

Mark Young

  • 250 Points 250 badge 2x thumb
Well thanks for that suggestion, but ... uh ... what settings?  I've been thru so many settings in the last couple days making sure that they were this or that.  Mobile data is on; data roaming has been both on and off over various tests and is currently off (and it shouldn't really matter since I'm not roaming).  Flight mode is off.  My APN settings seem to be correct (see my messages above).  My Messaging app settings don't seem to have anywhere where I can turn mms on or off.  

Latest news is that chomp doesn't send/receive mms either.  

The problem is the same on two different Galaxy S-3s and one iPhone 5s.  

I've tried with wifi on and with wifi off.  With wifi off I've been able to use the internet, tho' there has been occasional slowness (to the point of timing out sometimes).  

SMS, but no MMS.  Such is my current status.  
Photo of Mark Young

Mark Young

  • 250 Points 250 badge 2x thumb
Oh, and if you meant start the Settings app and go to the messages tab/command, then there is no such tab/command.  
Photo of Allan

Allan, Mobile Master

  • 56,586 Points 50k badge 2x thumb
Check to make sure the MMS Messaging Tab is turned on as shown below, I believe is what Goran is referring to.

(Edited)
Photo of Mark Young

Mark Young

  • 250 Points 250 badge 2x thumb
Ah, the iPhone!  I was on my Android.  Checking that out now.

So something arrived (from iPhone to Android).  There's no picture, but there is a Download button that pops up the message "Currently unable to download.  Please try again later."
Photo of Allan

Allan, Mobile Master

  • 56,726 Points 50k badge 2x thumb
Mark, at this point, I would contact Koodo. I have seen cases where this is fixed by Koodo enabling something on their end or doing a network reset on their end. It may be something simple that they can do to help you out.
Photo of Mark Young

Mark Young

  • 250 Points 250 badge 2x thumb
Thanks, Allan.  I think I'll try that.
Photo of Nick Malialis

Nick Malialis

  • 180 Points 100 badge 2x thumb
Hello. I tried that and I can not add photos. I cleared out my apn and added it back as you had above, and added the APN Type is "default,supl,mms"

Still can not add photos.
Photo of Robert

Robert, Mobile Master

  • 103,714 Points 100k badge 2x thumb
You mean send photos? Or you can't add them to the message? What phone do you have? Try another SMS app 
Photo of Nick Malialis

Nick Malialis

  • 180 Points 100 badge 2x thumb
Both, I can not add them to be able to send them. I have a Sony Xeperia 3. I am using the default SMS app.
Photo of Allan

Allan, Mobile Master

  • 56,586 Points 50k badge 2x thumb
Photo of Nick Malialis

Nick Malialis

  • 180 Points 100 badge 2x thumb
Replying to that thread now. Thank you for all the support.