Why can't I log in to self serve

  • 1
  • Question
  • Updated 2 years ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: SS App mentions

I cannot log in to the self serve page.  It will either just keep spinning while logging in or give me a 'page not available' error message.  I want to be able to see my account information. This is showing up in the Community Forum for the past several years.  Why can't Koodo fix this?
Photo of Michelle


  • 90 Points 75 badge 2x thumb

Posted 2 years ago

  • 1
Photo of Mathieu

Mathieu, Mobile Master

  • 60,788 Points 50k badge 2x thumb
To resolve any issues with any of the Koodo website, please try the following steps:

Make sure to use a web browser that the website was built to support. These web browsers are: Google Chrome, Mozilla Firefox, Safari and Internet Explorer. Please note that the default browser in Windows 10, Microsoft Edge has not been announced as supported by Koodo.
Clear the cache and cookies of the browser you are using.
Try using a different web browser. If another browser works, it is most likely an issue with your first browser. Try re-installing and checking its built in security features.
Try using a different device. If it works with another device, then there is a chance the issue is related to fire-wall or anti virus installed on the device
Shut down your router for a few minutes and turn it on. If you noticed it was very warm, you might want to consider replacing it. If it’s not too warm, then there is a chance their was a software glitch with it and restarting it will solve the issue
If by now your issue still persists, try using a different network such as at Tim Hortons/McDonalds or by using your mobile phone’s data connection. If it works there, then there might be an issue with your ISP.
If you still have issues, call Koodo! They are open from 9am to 9pm Monday to Friday. And 9am to 7pm on weekends.

I hope this helps, have a great day!
Photo of Michelle


  • 90 Points 75 badge 2x thumb

I have tried Chrome and IE.  On three different computers on different networks.  In different locations.  Cleared history and cookies.  Tried on mobile data connection on two different phones, one of which wasn't a Koodo phone.  Nothing works.  Thanks for your help.  Guess I'll have to call them.  I've tried too many combinations of device, network and browser for it to be anything other than Koodo's issue. 

Not very impressed with this, I was promised great service if I switched from Bell.

Photo of BC


  • 162 Points 100 badge 2x thumb
Hi Michelle,

Firstly, did you ever registered or successfully signed into Self Serve?  If the answer is no then you will have to register first.  You could do this on the web or using the App on your phone.  It will send you a sms message to verify your account ownership.  Hope this answers your question.
Photo of Michelle


  • 90 Points 75 badge 2x thumb
Thank you. I have registered and confirmed my account.
Photo of Melissa

Melissa, Employee

  • 11,708 Points 10k badge 2x thumb
Hey Michelle, it sounds odd indeed! If you give us a call, a rep will be able to assist you and reset your self-serve profile, which should do the trick. Please let us know how it goes :) 

This conversation is no longer open for comments or replies.