Why can't i get LTE coverage on my iphone 6? I'm in downtown toronto

  • 1
  • Question
  • Updated 3 years ago
  • Answered
Just activated my phone on koodo. It's an iphone 6 from the apple store, unlocked. Not once since the sim card was in have i had LTE. I've been up and running for 3 hours now. LTE is enabled and i've done a network re-set. Please help.

thanks
Photo of KidWunder

KidWunder

  • 80 Points 75 badge 2x thumb

Posted 3 years ago

  • 1
Photo of Robert

Robert, Mobile Master

  • 103,714 Points 100k badge 2x thumb
Hello, here's what could be the problem

1) Is your LTE active? (Settings > Cellular > Enable LTE)
2) Has your LTE ever worked on previous cells you had?
Photo of Eugene

Eugene

  • 1,748 Points 1k badge 2x thumb
Hi, KidWunder
I have had the same problem with my Nexus 5.
When I first purchased the phone, I was only getting HSPA or H, in an iPhone a 3G, instead of an LTE sign when my celluar data was turned on. However, I have waited for about a week and now, I seem to get LTE almost everywhere. Just try what Robert said above and if it still is not working don't sweat it! Give Koodo customer a call if you really want LTE services. (However, the LTE speeds and the high HSPA speeds are barely different so I wouldn't worry too much:)
Photo of KidWunder

KidWunder

  • 80 Points 75 badge 2x thumb
Thank-you both for replying.. these emails went to my junk folder and didn't see them til now. Yes LTE was enabled, but when I woke up this morning LTE is working fine. Not only is it working fine, but the cell signal is full even in my condo den, where i was getting no signal before i joined koodo, so pretty happy at the moment.

This conversation is no longer open for comments or replies.