Why am I not receiving certain text messages?

  • 1
  • Question
  • Updated 4 weeks ago
I just got an android phone with Koodo and I only receive texts from one person with an iPhone.  But everyone else I talk to, I only get bits and pieces. Some texts come through & some don't. They have iPhones as well. I tried turning my MMS off cause I thought that might have something to do with it but it didn't work. I used my boyfriend's iPhone as a phone when I needed to before I got this phone but his iMessage is turned off and he's using it now by himself. I only get texts come through from him. Can someone explain what's going on or offer suggestions? I even downloaded an SMS app cause I read that doing that might solve the issue but I still don't get all the texts from people. 
Photo of Alexandra Iancu

Alexandra Iancu

  • 140 Points 100 badge 2x thumb

Posted 4 weeks ago

  • 1
Photo of Mats

Mats

  • 21,994 Points 20k badge 2x thumb
See if this page helps you.

https://support.apple.com/en-ca/ht204270
Photo of Alexandra Iancu

Alexandra Iancu

  • 140 Points 100 badge 2x thumb
This is what confuses me because a.) I didn't use the same SIM card for my android phone, I got a new # and a new SIM card. And someone is still using the old phone I was using. My boyfriend. Plus his iMessage is off. So I'm not sure how any of that applies to me. But I'll give it a try, thanks. 
Photo of Mats

Mats

  • 21,994 Points 20k badge 2x thumb
The problem might not be on your end. The people with iphones might not have SMS enabled. They will have to enable send as SMS when imessage is not available.

  1. Open the Settings app and go to “Message”
  2. Locate the switch for “Send as SMS” and turn this to the ON position (if send as SMS is already on, try turning it off for about 10 seconds and then turn it back on again)

Taken from the page below about half way down.

http://osxdaily.com/2016/05/12/fix-iphone-not-sending-text-messages-sms/
(Edited)
Photo of Alexandra Iancu

Alexandra Iancu

  • 140 Points 100 badge 2x thumb
Okay thank you, I'll let everyone I talk to know, I think the problem is on their end so this helps a lot. Thanks again. 
Photo of Goran

Goran, Mobile Master

  • 97,450 Points 50k badge 2x thumb
You'll need to disable your own imessage then in order to receive all texts properly.
Photo of Alexandra Iancu

Alexandra Iancu

  • 140 Points 100 badge 2x thumb
It is disabled though. But thanks for the reply!
Photo of Goran

Goran, Mobile Master

  • 97,104 Points 50k badge 2x thumb
So you did everything as per the link Mats provided?
Photo of Alexandra Iancu

Alexandra Iancu

  • 140 Points 100 badge 2x thumb
Yes I did but my iMessage was already disabled as I said in my original post. I think the problem is on everyone else's end because they have iPhones & I have android so I doubt they have SMS enabled. 
Photo of Allan

Allan, Mobile Master

  • 62,252 Points 50k badge 2x thumb
Also get those people to delete their past conversations with you. That can sometimes cause some screwyness to happen since you went from iphone to android.
Photo of Alexandra Iancu

Alexandra Iancu

  • 140 Points 100 badge 2x thumb
Okay thanks a bunch. That's super helpful!