Why am I getting billed roaming charges in Sault Sainte Marie Canada because if soon Michigan towers

  • 1
  • Question
  • Updated 3 years ago
  • Doesn't Need an Answer
Photo of Chérie Zivny

Chérie Zivny

  • 80 Points 75 badge 2x thumb

Posted 3 years ago

  • 1
Photo of rikkster

rikkster, Mobile Master

  • 68,304 Points 50k badge 2x thumb
You probably have roaming turned on, on your phone. Sault Sainte Marie is quite close to the U.S. border which would explain the roaming charges.
Photo of Dave

Dave

  • 7,814 Points 5k badge 2x thumb
This is known as accidental roaming - US towers are more powerful so they pick up signals from our phones.

There may be a free addition if you live near a border, otherwise you would have to keep an eye on your bill to see that it does not happen again.

So you know most phones will say that you are connecting to US towers now
Photo of Chérie Zivny

Chérie Zivny

  • 80 Points 75 badge 2x thumb
I put it on airplane mode and they still charged me after I called them and told them how long I was staying etc....
Photo of Dave

Dave

  • 7,814 Points 5k badge 2x thumb
It can also take up to 90 days to be billed to your account.

Since your phone was in airplane mode there may be a problem with your phone....if it is under warranty then take it to a kiosk to send away for repair.....but talk to customer service/tech support first.
Photo of Dave

Dave

  • 7,814 Points 5k badge 2x thumb
You can also change the settings on your phone so that it only connects to koodo towers

Try calling tech support to make these changes :)
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
All you need to do (since you tagged android)

Navigate to

Settings... Wireless and networks... More.... Mobile networks.

Change NETWORK SELECTION to manual.

Your phone will perform a scan that may take up to 2 minutes. At the end of the scan you'll be presented with a list of available networks. Choose Koodo or Telus.

Note: this disables international roaming so if you go to the states and want service you'll have to change it back to automatic.

This conversation is no longer open for comments or replies.