Wheresoever I "roam", I am still at home

  • 1
  • Question
  • Updated 3 years ago
  • Answered
I live near Abbotsford, BC and every time I go to the Save-On grocery store my phone goes on to US "roam" so I don't want to use it. Anybody else had issues like this? If so is there any remedy, apart from shut if off, even though I am still well within Canada?
Photo of Robert Smith

Robert Smith

  • 70 Points

Posted 3 years ago

  • 1
Photo of Dennis

Dennis, Mobile Master

  • 187,512 Points 100k badge 2x thumb
Go to Settings>Carrier/Network> Turn off Automatic and select Koodo
Photo of Matthew Hill

Matthew Hill

  • 3,102 Points 3k badge 2x thumb
You must be close to a US Border, and the closest tower when you're at Save-On must be in the US.

Android : Settings > More(Or More Networks, should be the third or fourth option anyway) > Mobile Networks > Network Operators > and search for networks( This could take a couple of mintes to do) > When Koodo pops up, select it and your phone will no longer connect to anything else but a Koodo network.

iPhone: Settings > Carrier > Turn off automatic and wait for Koodo to pop up, select Koodo and that will be the only network your phone will connect to. +

This conversation is no longer open for comments or replies.