WHAT'S UP WITH 'LACK' OF BATTERY ? NEED PHONE NOW!

  • 1
  • Question
  • Updated 4 years ago
  • Answered
I have an Samsung Galaxy 4 (?) phone. last night it was at 16%, saying charge. So, I did. On 2 different chargers. It seemed to stop charging and showed up (all night, still doing it) with what appears to be a battery with green slowly, if at all moving as well as blinking white lights surrounding it at base. It has also had same, but with a small,yellow, battery (?) at bottom right that has a strike through it. I am going crazy as it appeared to be working a few times, still saying charge though. And, I can't get battery out and need it asap. Any ideas would be much appreciated. Thanks.
Photo of Fiona Sanders

Fiona Sanders

  • 170 Points 100 badge 2x thumb

Posted 4 years ago

  • 1
Photo of Jonathan I

Jonathan I, Mobile Master

  • 114,404 Points 100k badge 2x thumb
What do you mean you can't get the battery out? You can take off the back and remove it. Try that, remove the SIM card, and wait a little bit. Then put everything back together and try charging it with a different charger.
Photo of rikkster

rikkster, Mobile Master

  • 68,238 Points 50k badge 2x thumb
It's possible the battery may have 'swollen' making removal difficult, I've been reading a number of reports about this where the battery is no longer capable of keeping a charge, upon successive charges, the battery becomes hot and the case expands. You're better off taking the S4 into a Koodo kiosk and let a rep inspect the S4. They may suggest getting a new battery.

The small yellow battery with the diagonal strike through it means the battery isn't providing enough voltage to power the S4 or that the charger itself isn't providing enough power to charge the battery. Bring the phone and charger to your nearest Koodo retailer for inspection.
Photo of Dennis

Dennis, Mobile Master

  • 195,954 Points 100k badge 2x thumb
I'm sorry Fiona, but I am having the hardest time understanding your description.

It sounds like your battery is not charging properly and the battery warning (Saying that it needs to be charged) keeps popping up even though you have it plugged into the charger (and that you have tried 2 different chargers).

If this is correct then it sounds like there is either an issue with your power outlet, the micro usb port, or the battery.
Have you tried to charge your phone with a different power outlet or a USB port?
Does the charging start then stop? Have you tried jiggling the micro usb connector when it is plugged into the phone?
Photo of Fiona Sanders

Fiona Sanders

  • 170 Points 100 badge 2x thumb
I have taken out many times, for some reason (because I really need it ) I can't get it out. Isn't there a button or something to facilitate this ?

It worked for about 5 mins. was going to call you, then died again.

Very annoyed and fed up.

Ideas? Where's the battery spot, or am I imagining it?

Thanks
Photo of KaneSlavik

KaneSlavik

  • 6,464 Points 5k badge 2x thumb
You take it out the same way as you did the other times.
Photo of Dennis

Dennis, Mobile Master

  • 195,954 Points 100k badge 2x thumb
This is how your remove the battery:
https://www.youtube.com/watch?v=xBIEkb...

If it does not come out like the video, then follow what Rikkster's instruction above and take it to a Koodo kiosk
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
And to add to Roberts suggestion, stop trying to charge it as a swollen battery could catch fire or explode if you keep trying to charge it
(Edited)
Photo of Fiona Sanders

Fiona Sanders

  • 170 Points 100 badge 2x thumb
Thank's for your advice. Blurb done in haste as fed up & thought it was going to my ongoing dialogue with Koodo (not public forum), hence, lack of detail, etc. Battery indeed 'done', as it turns out after 2 visits to Koodo kiosk. They too had problems with it. Thank's 'rikkster' for providing the most useful advice; I had tried most of the above mentioned comments. As I didn't realize it was on the forum, I didn't see this until today.

This conversation is no longer open for comments or replies.