USA Verizon Phone Work on Kodoo Prepaid?

  • 1
  • Question
  • Updated 2 years ago
  • Answered
I have a casio g zone phone given to me from USA, I purchased kodoo prepaid SIM card, I can call out and send and receive texts (no pictures), any calls in go directly to voice mail, is there something I need to tweak to make all features work?
Photo of Kate

Kate

  • 130 Points 100 badge 2x thumb
  • in need of help!

Posted 2 years ago

  • 1
Photo of Mathieu

Mathieu, Mobile Master

  • 60,828 Points 50k badge 2x thumb
Hi Kate,

I'd turn the phone off, remove the SIM card (and battery if possible) and let it sit for a few minutes. Put the parts back together and then try again.
Photo of Ivan

Ivan, Mobile Master

  • 96,382 Points 50k badge 2x thumb
If this fails, I'd recommend performing a factory reset next (please remember to back up any important data).
Photo of Kate

Kate

  • 130 Points 100 badge 2x thumb
None of these suggestions worked?  Is it compatible with Kodoo network?
Photo of rikkster

rikkster, Mobile Master

  • 67,084 Points 50k badge 2x thumb
It's compatible with Koodo's 3G network, but not 4G LTE. (see: http://willmyphonework.net/)
Photo of Kate

Kate

  • 130 Points 100 badge 2x thumb
So, its a 4g LTE, so it will not work with Kodoo? 
Photo of rikkster

rikkster, Mobile Master

  • 67,084 Points 50k badge 2x thumb
Correct. Verizon uses 700 MHz for 4G LTE. Koodo uses 1700/2100 MHz for 4G LTE. 3G appears to working because your son is able to send and receive texts and make calls. I think the APN settings need to be tweaked if he can't send or receive picture messages. Below are Koodo's APN settings. To access APN settings, go to: Settings > More... > Mobile Networks > Access Point Names - tap Koodo SP.

Name: Koodo
APN: sp.koodo.com
Proxy: Leave blank
Port: Leave blank
Username: Leave blank
Password: Leave blank
Server: Leave blank
MMSC: http:// aliasredirect.net/proxy/koodo/mmsc (no space between http:// and aliasredirect)
MMSC proxy: 74.49.0.18
MMS port: 80
MCC: 302
MNC: 220
Authentication type: Leave blank
APN type: Leave blank

Compare the settings above to the phones' APN settings. Remember to select Save/Done when finished editing or creating a new APN.

Also, try setting the phone to 'WCDMA Only'. This can be done one of two ways. From the phones dialpad enter *#*#4636#*#* tap Phone Information and scroll down to Set Preferred Network Type. Tap the dropdown menu and select WCDMA Only. Or, go to: Settings > Mobile networks > Network mode and if the option is available, select WCDMA Only. This prevents the phone from scanning for an incompatible 4G LTE network and could save battery in the process.
(Edited)