Us roaming text plan not working

  • 1
  • Question
  • Updated 12 months ago
I have set up an unlimited text roaming plan while on vacation in the US but I am not receiving texts nor am I able to send text messages. I have been reading advice from the community and have tried everything I could find.
I've manually connected to the carrier, tried both networks that are available to the area
My data is on although I have turned off the cellular data use for all of my apps yet I've STILL been charged for data that I do not recall using.
My roaming is turned on
I've tried with both my iMessage off and on
I will get texts on my iPad when I'm connected to wifi but never receive them on my phone. I would just rather not have this plan that doesn't seem to work and would rather just use wifi when I'm connected.
Photo of courtney

courtney

  • 110 Points 100 badge 2x thumb
  • frustrated

Posted 12 months ago

  • 1
Photo of Goran

Goran, Mobile Master

  • 90,654 Points 50k badge 2x thumb
Have you tried restarting? And if that doesn't work pulling out your Sim card, putting it back in, and then restarting?

Have you disabled Wi-Fi assist to ensure you don't get hit with data? What does your phone say about data usage?
Photo of courtney

courtney

  • 110 Points 100 badge 2x thumb
I had tried to restarted my phone but I do now have anything small enough to extract the SIM card. My wifi assist is never on.
my plan said this morning that 2 MB of my international data was used and I left my phone In my room for the day since taking it with me would be useless. Even though I was away from my phone all day now it's saying 3 MB of data has been used.
Photo of Melissa

Melissa, Employee

  • 11,748 Points 10k badge 2x thumb
Hey Courtney! Have you noticed that this is happening only with iPhone users? If you keep iMessage off you won't receive text messages on your phone from other iMessage users if you are not connected to data, which is most likely why you are getting them on your iPad. Did you turn off cellular data usage for iMessage on your phone? Let us know! 
Photo of courtney

courtney

  • 110 Points 100 badge 2x thumb
I have tried to have iMessage both off and on and I have not received text messages or iMessages from iPhones or androids even while connected to wifi. Cellular data for iMessage and all apps had been turned off since I don't have data but even while connected to wifi I don't receive a single message. Somehow my phone used an extra MB of data while sitting on a counter all day unused and connected to wifi despite having all of my apps set to no data use
Photo of David

David, Mobile Master

  • 89,034 Points 50k badge 2x thumb
If you have not added your Apple ID to iMessages on your phone, that may be one reason why it works for your iPad, but not your phone. Check and make sure both are set up the same.
The system uses data not attached to any particular App, which may explain the data usage you see.

You should be receiving messages from Android users without question, and my experience would suggest iMessages should also work when set up as you describe.
Photo of Melissa

Melissa, Employee

  • 11,748 Points 10k badge 2x thumb
Mmm that sounds strange!
For the data, I recommend going into your settings > cellular > cellular data options> and turn data roaming off.  This will block all data connections to your phone, with the exception of Wi-Fi.
You need to have a signal from a local carrier to be able to text as this doesn't work through Wi-Fi only.  Can you make sure that you have an active network signal? I also recommend restarting your phone to see if it makes a difference. Let me know what happens! 
Photo of courtney

courtney

  • 110 Points 100 badge 2x thumb
I've restarted my phone multiple times, and the network connection has been consistently at 3-5 bars. I've attempted to manually connect to both AT&T and T-Mobile with no luck on either network
Photo of Dennis

Dennis, Mobile Master

  • 187,452 Points 100k badge 2x thumb
So what network are you connecting to that gives you 3-5bars?
Photo of Dennis

Dennis, Mobile Master

  • 187,452 Points 100k badge 2x thumb
Maybe try Settings > General > Reset > Reset Network Settings

Note that any wifi passwords will be forgotten
Photo of courtney

courtney

  • 110 Points 100 badge 2x thumb
AT&T is the network that has the strongest connection
Photo of Dennis

Dennis, Mobile Master

  • 187,452 Points 100k badge 2x thumb
Its weird that you can automatically connect to AT&T but you cant manually connect to AT&T.  

If the network reset doesnt work that I mentioned above, try to Hold the power and home button until you see the apple logo.  When you see the apple logo you can release all the buttons.  This does a Hard restart.  See if that helps