US Roaming Prepaid Add-Ons Not Working

  • 1
  • Question
  • Updated 1 year ago
I purchased both a US Roaming 5 minute Talk Booster and US Roaming 500MB Booster for my Alcatel One Touch phone. I had a vacation in California early this month. Upon arrival I was not able to connect to the network at all and was not able to use my boosters during my whole 8 day vacation.

I will be going back in September, so I am happy to keep these boosters on my account, however I want to know why they didn't allow me to connect and use the roaming I purchased on my account and how can I fix this for next time?

My roaming was ON in my phone settings (data enabled, data roaming)
Photo of Tamara Ferguson

Tamara Ferguson

  • 100 Points 100 badge 2x thumb

Posted 1 year ago

  • 1
Photo of Allan

Allan, Mobile Master

  • 56,526 Points 50k badge 2x thumb
There have been a few cases with Prepaid in which you manually have to select the carrier on your phone instead of having it search automatically for one. This could have been the problem.
Edit: I see from another post you have tried this. What happened when you tried to connect manually? Were you able to select a carrier, did no carriers appear, did they appear but say forbidden?
(Edited)
Photo of Tamara Ferguson

Tamara Ferguson

  • 100 Points 100 badge 2x thumb
No carriers appeared when I was in the states. Unfortunately it will be September before I can try to connect again.
Photo of Mayumi

Mayumi, Mobile Master

  • 112,704 Points 100k badge 2x thumb
Did you try restarting your phone too? If not, it worth to try next time. 
Photo of Tamara Ferguson

Tamara Ferguson

  • 100 Points 100 badge 2x thumb
yes, the phone was turned off on the airplane. it was a fresh start when i landed in the states