Updating Galaxy S2X from Mac Kies

  • 1
  • Question
  • Updated 4 years ago
  • Answered
I'm trying to update software on my Galaxy XII S (currently running 4.0.4) with my MacBook(running 10.9.2). I just installed Kies(3.0.1.14032_5) onto my Mac. When I plug my phone in via USB, the computer doesn't realize it's plugged in (not on Kies or on Finder). Help appreciated :)
Photo of Regan Riordon

Regan Riordon

  • 452 Points 250 badge 2x thumb

Posted 4 years ago

  • 1
Photo of Ahmad

Ahmad

  • 96,102 Points 50k badge 2x thumb
Have you tried using your USB and plugging your phone into another computer? Your USB cord or even your computers USB port could be faulty
Photo of Regan Riordon

Regan Riordon

  • 452 Points 250 badge 2x thumb
I've tried a few different chords. The port should be fine (I use it with an external hard drive and have no problems). Are there settings on the phone, the MacOS, or Kies that need to be enabled?
Photo of Ahmad

Ahmad

  • 96,102 Points 50k badge 2x thumb
Make sure your USB connection is enabled

Settings -> Click "More.." under the Wireless and Network -> USB utilities
Photo of Regan Riordon

Regan Riordon

  • 452 Points 250 badge 2x thumb
Under USB Utilities, it reads "USB Mass Storage, Tap the button bellow to copy files between the computer and SD card." When I tap the button, a message pops up saying "Connect USB cable to use mass storage", but the cable is connected..
Photo of Ahmad

Ahmad

  • 96,102 Points 50k badge 2x thumb
Hmmm honestly I'm stumped. The only thing I would do at this point is try plugging into different computers, with multiple different USB cables. If the problem persists, I think there may actually be something wrong with your actual phone

Hopefully someone else can come chime in if they have an idea on how to fix this
Photo of Chad Burr

Chad Burr, Mobile Master

  • 204,088 Points 100k badge 2x thumb
I'll be honest I don't own a mac nor have I ever used one that wasn't sitting behind a shelf tag with the words "best buy" on it.

From what I've read, make sure your java runtime is up to date

Also try uninstalling the kies software and downloading the latest kies form samsungs website. If you have multiple usb ports, try them all one by one.

Let us know.
Photo of Regan Riordon

Regan Riordon

  • 452 Points 250 badge 2x thumb
Installed Kies earlier today from the Samsung website, and just updated/installed java runtime. Still not showing up.
Photo of KaneSlavik

KaneSlavik

  • 6,464 Points 5k badge 2x thumb
You can also call Apple/Samsung as well for assistance. I say Apple because of the Macbook.
Photo of rikkster

rikkster, Mobile Master

  • 68,950 Points 50k badge 2x thumb
With the S2x disconnected from your computer, go to Settings > Developer options and enable USB debugging by placing a checkmark in its box. If you haven't already done so, reboot your computer, then open Kies and reconnect your S2x. Kies should now recognize your S2x.
Photo of Regan Riordon

Regan Riordon

  • 452 Points 250 badge 2x thumb
Doesn't seem to be working.
Photo of rikkster

rikkster, Mobile Master

  • 68,950 Points 50k badge 2x thumb
Ok, try this.

Photo of Regan Riordon

Regan Riordon

  • 452 Points 250 badge 2x thumb
No Dice :(
Photo of rikkster

rikkster, Mobile Master

  • 68,950 Points 50k badge 2x thumb
I think we've pretty much exhausted all possibilities. Samsung Kies is problematic at best even for Windows users and was the source of numerous complaints during the initial upgrade for the S2x from ICS to JellyBean.

One other option to try.

Disconnect the S2x from your computer. Tap the Phone icon and from your dialpad, enter *#7284# Under the heading USB, select "Modem" mode and exit the screen by tapping the back button on your S2x. Tap the Phone icon once again and redial *#7284# Under USB select “PDA” mode then tap the back button on your S2x.

Launch Kies (wait for it to launch completely) then connect your S2x. Do not do anything on your S2x. Allow Kies to download the necessary drivers and establish a connection with your S2x. Within a couple of minutes, the device should be connected to Kies.

This conversation is no longer open for comments or replies.