Unable to process on the Self Serve app

  • 3
  • Question
  • Updated 5 years ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members.

Every time I use the Koodo Self Serve app and go to check my usage it says "Unable to process your request. Please check your information and try again." Is there a way to fix this because I cannot see my usage and it's a problem.
Photo of Lyssa H

Lyssa H

  • 90 Points 75 badge 2x thumb
  • upset and frustrated

Posted 5 years ago

  • 3
Photo of Myke


  • 45,100 Points 20k badge 2x thumb
Make sure you're entering in the correct log in information(test on a PC first). You will get that message if the information you are entering isn't correct.
Photo of Khaleila


  • 4,102 Points 4k badge 2x thumb
Hey Lyssa, Are you still having issues with your Self Serve app? Please keep us posted.

If you see a good answer, give it a star.
Photo of Jorden

Jorden, Mobile Master

  • 33,384 Points 20k badge 2x thumb
If it's on an iPhone try updating the app. Mine has worked better since the update to version 2.0

If it's still not working, the work around is to hit log out and then log back in you should be able to see your usage then. There is a glitch that the app makers have had trouble tracking down, and it seems to be tied to having "keep me logged in checked" but that's as far as I've been able to troublshoot/find a work around for.

This conversation is no longer open for comments or replies.