Unable to make calls problem, Samsung S3

  • 6
  • Question
  • Updated 2 years ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members.

I have a Samsung S3 and for the past couple weeks, at random times, I noticed I cannot make any calls. As soon as I press the "call" button, I get "call ended". When I restart my phone, it works but then stops throughout the day. What could be the issue??
Photo of Kat

Kat

  • 212 Points 100 badge 2x thumb

Posted 4 years ago

  • 6
Photo of John Lee

John Lee

  • 36,724 Points 20k badge 2x thumb
I'm not too sure. Maybe you could try a battery pull which is taking out your battery and SIM card for 30 seconds - 1 minute and then putting it back in and restarting the device. Also, are you on Koodo Monthly or Prepaid?

If you are on Prepaid, maybe you have no more talk boosters left on your account and need to top up and buy some more?

If all fails, you could always go to the nearest Koodo shop and ask for assistance. If it is under warranty, you can get a replacement device since it isn't physical damage.
Photo of Penny Harris

Penny Harris

  • 60 Points
I just tried pulling the battery out for 1 minute and it worked!! Thanks John Lee.
Photo of jhtrainingservices

jhtrainingservices

  • 232 Points 100 badge 2x thumb
Same for me when I switched from Bell to Koodo. The fix was to disable the LTE. Found this sollution. 1. Disable LTE

While the phone is powered on, remove its back cover and eject the SIM card.
The phone will prompt a restart once it detects the absence of the SIM card, so simply restart it.
Once the device is powered on, dial *#2263#.
Choose WCDMA and WCDMA All.
Put back the SIM card to its slot.
Reboot the Galaxy S3.
http://thedroidguy.com/2014/03/soluti...
Photo of Kat

Kat

  • 212 Points 100 badge 2x thumb
I'm on a monthly plan, never had any issues. Also the problem is only with outgoing calls, it disconnects as soon as I hit the call button. I've always been able to receive calls, send text messages and everything else.

I was told to clear my phone cache see if that helps, or maybe there's something wrong with my sim card? Do you know if I would get a replacement free or charge?
Photo of Jonathan I

Jonathan I, Mobile Master

  • 114,344 Points 100k badge 2x thumb
You could ask but SIM cards are consumable items. If it happens too often after replacing it then something's wrong with the phone, methinks.
Photo of DJ

DJ

  • 792 Points 500 badge 2x thumb
You will probably need to pull your battery and your sim card leave it out for 5 minutes and put it back it. This will reset your phone to the tower most frequently used.
(Edited)
Photo of Kat

Kat

  • 212 Points 100 badge 2x thumb
trust me i have tried and it only works for a short while. the only way is to click the airplane mode on and off again.
Photo of Paul Deschamps

Paul Deschamps, Mobile Master

  • 199,438 Points 100k badge 2x thumb
Do you have the proximity sensor set to turn the display off when you place the phone to your head so you don't hit anything including the end call icon with your ear. Make a call and place your hand covering the top part of the phone where the sensors are the ear piece, if the display doesn't shut off go into your settings and make sure your proximity sensor is enabled.
Photo of Carol

Carol

  • 60 Points
I'm having the same problem.
It's happening at multiple locations, and I always have 4 bars (signal strength) when trying to make the call.
I have to restart the phone to make outgoing calls. This happens a couple times a day now.

My phone display does turn off when I hold it to my ear, so it's not because I'm accidentally hitting the 'end' button.

I've been googling this and found alot of people with different carriers are having this problem.
I haven't found the cause or fix for this problem yet.
Photo of VictoriaJ

VictoriaJ

  • 100 Points 100 badge 2x thumb
I have this problem as well and have been since i got the phone (December 24th) after changing the sim card, factory resetting the phone, getting a new phone from Koodo the issue still persists with my new phone, Apparently it's caused by the Samsung update that was done in December. The only fix that works is enabling flight mode and then disabling it....it's ANNOYING but it gets it working until it decides to act up again....it's a real piss off that's for sure.
Photo of Winston G

Winston G

  • 90 Points 75 badge 2x thumb
I have the same problem brand new phone S3 and cannot make two call in a row when contacted the customer service they pretended they didn't know ...I this is the problem between Samsung Electronic and Koodos why are they giving the phone to people with contracts.........from January untill now I have not get a good service .
Photo of Ivan

Ivan, Mobile Master

  • 96,382 Points 50k badge 2x thumb
While I do sympathize with your situation, is there a reason why you have not returned your phone for an exchange before the 15 day return period expired? I mean, if you had nothing but trouble with this device right from the start then why choose to keep it?

You are more than free to seek legal advice, but it's very unlikely that it will be cheap or that it will work in your favor. The contract that you have signed is in no way against any Canadian laws or wireless regulations. You may, however, have a case against Samsung Canada but the fact is that you have not dealt with them yet.

Your device is under warranty. I advise you to request a warranty repair from customer service. Be patient. The most that Koodo (or any other provider) can do is try to troubleshoot things with you here or over the phone, but warranties are handled by the manufacturer (usually through an authorized repair centre such as Flextronics in Newmarket, Ontario). Koodo will cover the shipping costs.
Photo of Paul Deschamps

Paul Deschamps, Mobile Master

  • 199,438 Points 100k badge 2x thumb
Virtual star Ivan

Winston I don't know if Koodo pretended that there was not an issue with the S3 that made it inoperable as I had the Galaxy S3 for a full year and had not a single issue with the phone at all other than it was a slow device after awhile but nothing that made it not work as intended. I'm meaning towards user error in not understanding the UI or a setting that changed after an update ,if it was an issue Samsung would have fixed the issue ages ago they aren't Ines to just let an issue ruin their reputation with customers .
Photo of Winston G

Winston G

  • 90 Points 75 badge 2x thumb
I am going to seek legal advice i think this is ripping off consumers and the CCTS /Government do nothing ..........why dont they give Verizon to come in the market since this is a problem they can fix ...
Photo of Winston G

Winston G

  • 90 Points 75 badge 2x thumb
I have now have a lawyer who is interesting in my care is there any one want join me.....
Photo of Timo Tuokkola

Timo Tuokkola, Mobile Master

  • 139,982 Points 100k badge 2x thumb
No, feel free to waste your own money.
Photo of Zaphod Beeblebrox

Zaphod Beeblebrox

  • 50,798 Points 50k badge 2x thumb
Good luck with that. A lawyer won't fix a technical issue. By the looks of the previous posts, you have not returned the phone within the 15 days as mentioned by Ivan. Verizon cannot fix a problem that has nothing to do with them. There is always a fix for everything and if you refuse to do such fixes (worst case scenerio is getting a different phone) then the cost of a lawyer is all on you. Have you called Samsung yet? Based on your post, probably not. Again, I wish you good luck..

FYI - I highly doubt that the agent was pretending anything.

I recently found out that the S3s that have 4.3 OS are the ones having the issue with calling.
Photo of Winston G

Winston G

  • 90 Points 75 badge 2x thumb
Samsung electronics Canada is not address the problem for the s3 koodo is not finding a solution for its customers what is the next step then..
I have done all the thing you guys mention and no solutions the the problems
Photo of Timo Tuokkola

Timo Tuokkola, Mobile Master

  • 139,982 Points 100k badge 2x thumb
What, didn't find any takers for your lawsuit?
I have the same problem. Within 14days telus replaced my phone as everytime I drove outside the city I could not make a call. Phone replaced and now calls still end but if I reboot I can get it running again. Very annoying. Wish there was a fix!
Photo of rikkster

rikkster, Mobile Master

  • 67,080 Points 50k badge 2x thumb
Check which Android version you have, chances are you're probably running version 4.3. (to verify, go to Settings > scroll down to and tap About device/phone). There is the option of downgrading to an older Android version like 4.1.2. or 4.1.1. To give you an idea as to what's involved, I've posted a link that shows how to downgrade from 4.3 to 4.1.1.

http://forum.xda-developers.com/showt...

Other than that, I haven't been able to locate a quick fix method that repairs the issue you're describing. The other option is to wait and see if Samsung comes out with an update that will hopefully resolve this problem.
Photo of marion c

marion c

  • 60 Points
I have the older Android version 4.1.2. and since I got this phone, I have had difficulty making calls at times. As soon as I dial the number, the call is immediately ended without ringing. I try the landline next to me and that call is immediately ended. I try several other numbers, all calls are immediately ended. An hour later I try dialing again and finally it rings. Switching off and on the flight mode does not work for me. I will try taking out the battery for 5 minutes and see if this works the next time it happens. Even if it works, I should not have to do this in order to make a simple call. My phone is under warranty so I will be sending it back for repairs or replacement shortly.
Photo of Sarah

Sarah

  • 60 Points
OMG! i have the same phone and same exact problem! i switch on the flight mode then switch it back off immediately and it magically starts working again. its soooo irritating -_-
Photo of Timo Tuokkola

Timo Tuokkola, Mobile Master

  • 139,982 Points 100k badge 2x thumb
The latest update for the S3 should fix this problem. It should have been pushed out to everyone by now.
Photo of Sugar

Sugar

  • 94 Points 75 badge 2x thumb
My boyfriend and I have the same problems with our s3's he also has a problem with his back button not working sometimes and right now im having a problem with the battery not holding a charge even after they replaced the battery and i did a factory reset...instead of turning your phone right off you can go into Airplane mode and back to regular and that works for the calling thing, but other then that when we went to the koodo store the girl told us that its the firmware of the phone so not much can be done/ Never buying a samsung phone ever again, never had so many problems with one phone that never gets used hardly
Photo of rikkster

rikkster, Mobile Master

  • 67,080 Points 50k badge 2x thumb
Check your Android software/firmware version. Go to Settings > About phone and look under Android version. An update was pushed out in July of this year and you should be on Android version 4.4.2. If you're running on an earlier version of Android, the update may solve the issues you're experiencing.

To update the software go to: Settings > About device > Software update and tap Update.
Photo of Bob Pinney

Bob Pinney

  • 70 Points
Same issue. My phone says "Your device has been modified. Software updates are not available". factory reset same message
Photo of Nandan WP

Nandan WP

  • 60 Points
ur 4n rooted
Photo of Doug Gruber

Doug Gruber

  • 70 Points
this is still going on? why are they selling these phones when its obvious they crash all the time. If its not the "unfortunately contacts has stopped" then its messaging that stops. what a piece of crap. updates fixed it for about five days at best.
Photo of Bob Pinney

Bob Pinney

  • 70 Points
I am having several issues with the Samsung Galaxy SIII GTI9300 unlocked. The phone was received 10 days ago and I cannot reliably make or receive calls. I have spent upwards of 15 hours trying to solve the phone issues and have concluded that it is a Samsung phone problem.
I purchased a Straight Talk SIM and set the phone up with Straight Talk. I have been a Straight Talk customer for a year with 2 GSM phones that work well. There is an AT&T tower next to my home. The new phone has full bars. Android version 4.1.2
Symptoms:
1. Phone sometimes calls out once but connection is bad. On the next and subsequent attempts will not connect and the call ends. Sometimes quickly, sometimes after 30 seconds.
2. Phone sometimes will allow me to answer a call, sometimes not.
3. Phone usually allows texting in and out.
4. Phone usually works when I go outside
5. Phone connects well to my WiFi and works OK on the mobile data network
Actions:
1. Straight Talk reset my phone/sim , pinged the tower and concluded that everything was OK(twice)
2. I did an internet search and found that this is a common problem with the Samsung SIII on multiple carriers.(t-mobile, AT&T,Sprint)
3. Performed the standard procedures, i.e. factory reset, hard reset, reseat sim, reseat battery, deleting cache, airplane on/off, signal booster app. Leave the phone off without battery, ect ect
4. When I attempt to update after a factory reset, the phone updates. The next attempt says that the phone has been modified and cannot be updated.
5. Several complainants have had their phones replaced and the problem persisted but some were resolved, I’m not sure if this is a solution
This is a business phone and causing a lot of frustration. Anything that you can suggest to alleviate this would be greatly appreciated.

This conversation is no longer open for comments or replies.