Unable to send/receive texts in the US.

  • 1
  • Question
  • Updated 1 year ago
I am in the US. I have signed up for the unlimited calling and texts add on for the US. I am unable to send text messages. I am able to send iMessages when connected to WiFi. I have reviewed the Apple guidance and no change. Have also powered off my iPhone 5 with no luck.
Photo of Paul

Paul

  • 160 Points 100 badge 2x thumb

Posted 1 year ago

  • 1
Photo of David

David, Mobile Master

  • 93,400 Points 50k badge 2x thumb
Is there any carrier shown at the top of you phone?
Are you on a post-paid or pre-paid plan?
Photo of Paul

Paul

  • 160 Points 100 badge 2x thumb
T-Mobile shows. 3 bars. I am on regular plan where I am billed monthly. I have confirmation of my roaming add-on being active.
Photo of Paul

Paul

  • 160 Points 100 badge 2x thumb
Phone calls, in and out work. I have turned off iMessage. Also restarted phone a number of times. Still no luck..
Photo of BobTheElectrician

BobTheElectrician

  • 66,696 Points 50k badge 2x thumb
Not experienced on iPhone, but can you manually choose AT&T as network provider? Works on Android.
Photo of Deborah Grey Smith

Deborah Grey Smith

  • 60 Points
I have Android, but I know that if/when my text messages are too long or carry a photo attachment, they're no longer SMS but MMS (multimedia message). MMS messages use the data plan and need to have data roaming turned on. Send photos or long messages via email instead, when you're connected to wireless.
Photo of Brent Foreman

Brent Foreman

  • 774 Points 500 badge 2x thumb
Try with data roaming on. This is only thing that worked for me but be careful of apps etc in background.
Photo of Mayumi

Mayumi, Mobile Master

  • 114,446 Points 100k badge 2x thumb
If I have a  "Talk & Text Roaming Add-on", then I wouldn't want to turn data roaming on.
If I need data connection, I'll wit to connect to WIFI ;)
Photo of Paul

Paul

  • 160 Points 100 badge 2x thumb
Still no luck texting in US. Have US talk and text add on for an iPhone 5. can make and receive phone calls. T Mobile carrier shows on the phone. have connected to T Mobile manually. have rebooted the phone a number of times. only able to send texts using iMessage when connected to WiFi or when data is turned on....don't want to incur data charges.
Photo of Allan

Allan, Mobile Master

  • 61,490 Points 50k badge 2x thumb
The contact that you are sending the message to, does it have an email or something else in the contact that it would trying to be sending an iMessage be default to? Instead of choosing a contact try manually inputting the number and sending a text.
Photo of Paul

Paul

  • 160 Points 100 badge 2x thumb
Thanks. I have manually entered the phone number to send a text message and it still does not work. With WiFi turned off and data roaming turned off, when trying to send a text, I get the following message: "Cannot Send Message. iMessage needs to be enabled to send this message."
Photo of David

David, Mobile Master

  • 92,924 Points 50k badge 2x thumb
If the recipient has received iMessages from you before, you would have to delete any past conversations with that individual, or connect to data to send them a message.  
Photo of Paul

Paul

  • 160 Points 100 badge 2x thumb
This seemed to work. Thanks David.
Photo of David

David, Mobile Master

  • 92,924 Points 50k badge 2x thumb
YAY!