Unable to get referral credit after activating a new post paid account

  • 1
  • Question
  • Updated 1 year ago
  • Answered
  • (Edited)
I used a referral link from an acquaintance and received an "Activate now to get your rewards" email from Koodo as confirmation. I then went and activated a new post paid account. But when I try to put my new Koodo mobile number, I get the message "This account identifier is already in use." Please help.
Photo of RM

RM

  • 110 Points 100 badge 2x thumb

Posted 1 year ago

  • 1
Photo of Allan

Allan, Mobile Master

  • 62,522 Points 50k badge 2x thumb
Do you already have a self serve account created?
Photo of RM

RM

  • 110 Points 100 badge 2x thumb
Thanks for your response. Yes I have already created a self serve account.
Photo of Dennis

Dennis, Mobile Master

  • 196,140 Points 100k badge 2x thumb
Were you a koodo customer previously?
Photo of RM

RM

  • 110 Points 100 badge 2x thumb
Never
Photo of Ranjan

Ranjan, Official Rep

  • 30,412 Points 20k badge 2x thumb
Hey RM - can you send us the details of the issue using this link? An agent will look into the matter and help resolve the issue if there is a problem with your login/profile. 
Photo of RM

RM

  • 110 Points 100 badge 2x thumb
A week has passed and this has still not been resolved in spite of several back and forth emails. :-(
Photo of Ranjan

Ranjan, Official Rep

  • 30,412 Points 20k badge 2x thumb
RM - I'm unable to find an account matching your email, but do see one with the same name - phone number ending in 92. Is that correct?
Also, can you give us any more info. with regards to the back-and-forth? What were you told/advised so far?
Photo of RM

RM

  • 110 Points 100 badge 2x thumb

Yes that's correct...3292.

Koodo customer service tells me that I became a Koodo customer on December 2, 2016. I have absolutely no idea from where they have picked up this date and neither has the customer service clarified it. Ever since I came to Canada I have been a Fido customer. On June 10, 2017 I became a Koodo customer for the first time.

Anyways I have given up on this now.Thanks for your help!


(Edited)
Photo of Ranjan

Ranjan, Official Rep

  • 30,412 Points 20k badge 2x thumb
Hi there - so here's what I'm seeing:

Previous activation: your phone number belonged to someone else in the past, which would explain why it would show up in the system as an activation from an earlier date; that said we are able to verify that it was re-issued in June when you activated.

The part I'm unable to figure out is that I don't see a profile in our referral system matching your name, email, or phone number (I've checked both names and emails you had attached to this profile). Did you follow these steps and create a profile prior to activating PLUS go back and input your number to complete the referral once you activated?

If the correct steps were not followed (i.e. if you did not register/create a profile on the Referral site, then that would explain why there's no record of this and why the referral can't be processed)