U.S. Roaming Data/Text/Talk Booster isn't working

  • 3
  • Question
  • Updated 8 months ago
  • Answered
I have a Active Samsung Galaxy S6, I just moved to hawaii from Canada, and added U.S. Roaming Data/Text/Talk Booster to my koodo prepaid account. Neither one of the booster is working, and it has been over an hour. I have reception, my location is working great.
Photo of Miki Gyula Nagy

Miki Gyula Nagy

  • 180 Points 100 badge 2x thumb
  • frustrated

Posted 2 years ago

  • 3
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,968 Points 100k badge 2x thumb
In your data usage settings be sure to turn on Data Roaming

And also be sure to restart your device.
(Edited)
Photo of Miki Gyula Nagy

Miki Gyula Nagy

  • 180 Points 100 badge 2x thumb
Both the Mobile Data, and the International Data Roaming is turned on. And I did restart my device. I should of mentioned it.
(Edited)
Photo of Ranjan

Ranjan, Official Rep

  • 28,708 Points 20k badge 2x thumb
Hi Miki - this new U.S. roaming booster was just launched today, and I've been told there is a small percentage of customers that may not be eligible to benefit from it just yet. This is a known issue and a fix should be in place within the next 24 hours. If you're comfortable sharing your phone number, I'll pass your details along to the team to verify that this is the problem you're experiencing (I can mask your number once you share it to ensure it's not visible to others after).
I have bought a booster and my phone will not send text or call- any ideas?
Photo of David

David, Mobile Master

  • 89,024 Points 50k badge 2x thumb
Have you followed this suggestion below?

Miki Gyula Nagy

K I got it to work, I manually installed it to at&t in the network operators settings, and now it is working
Photo of Paul Veriker

Paul Veriker

  • 60 Points
Hi. Paul Here. How do you manually install AT&T. Thanks
Photo of BobTheElectrician

BobTheElectrician

  • 61,868 Points 50k badge 2x thumb
Read Chad Burr's post at the bottom of this page.
Photo of Mayumi

Mayumi, Mobile Master

  • 112,704 Points 100k badge 2x thumb
I think that install means s/he selected network manually.
Setting > Connection or Mobile network > Network operators and select AT&T.

If it didn't work, can you start your question using this link?
https://community.koodomobile.com/koodo/topics/new

We need more info to help you.  Ar you postpaid or Prepaid?
What phone do you have? Do you have any Roaming add-on?...etc.
Photo of Miki Gyula Nagy

Miki Gyula Nagy

  • 180 Points 100 badge 2x thumb
My number is xxx-xxx-xxxx
(Edited)
Photo of Ranjan

Ranjan, Official Rep

  • 28,384 Points 20k badge 2x thumb
Thanks Miki - will let you know if I hear anything different to what I mentioned below, otherwise the service should be up and running tomorrow. 
Photo of Miki Gyula Nagy

Miki Gyula Nagy

  • 180 Points 100 badge 2x thumb
Alright thanks
Photo of Ranjan

Ranjan, Official Rep

  • 28,384 Points 20k badge 2x thumb
Hey Miki - can you try power cycling your phone? (shut it off, and then power it back up). The team has manually provisioned the booster on your account and it should work once you try this. Let me know. 
Photo of Miki Gyula Nagy

Miki Gyula Nagy

  • 180 Points 100 badge 2x thumb
Just tried it, it still does not work. When I try to text it says it will send it when service becomes available while having 4-5 bars.
(Edited)
Photo of Ranjan

Ranjan, Official Rep

  • 28,384 Points 20k badge 2x thumb
Hmm.. odd. I'll follow-up with the team again to keep looking into this. In the meantime, try rebooting the phone again, remove and re-insert your SIM card, ensure cellular data and data roaming are on, etc.
Photo of Miki Gyula Nagy

Miki Gyula Nagy

  • 180 Points 100 badge 2x thumb
K I got it to work, I manually installed it to at&t in the network operators settings, and now it is working
Photo of Ranjan

Ranjan, Official Rep

  • 28,384 Points 20k badge 2x thumb
Glad to hear it's working! Let us know if you need anything else or run into any issues. Enjoy Hawaii!
Photo of Douglas Williams

Douglas Williams

  • 60 Points
Thanks for sharing, I too had to switch my network to ATT in Florida and finally got it to work. Koodo should tell us this when we purchase the add on.
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,968 Points 100k badge 2x thumb
They don't because it should grab the strongest available network be it AT&T or T-MOBILE.
Photo of Ken Butt

Ken Butt

  • 62 Points
My phone isn't working either, what do you mean by switching to at&t and where do you do that in the settings
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,968 Points 100k badge 2x thumb
Ken, ON Android you'd goto
Settings....wireless and networking...more...mobile networks....network selection

Change to manual
The phone will scan which may take a few moments and then present you with a list of available networks. Choose each one until you get a connection.

Make sure to set this back to automatic upon your return to canada and restart your device.