Turning off 30day Roaming package early

  • 1
  • Question
  • Updated 10 months ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: No longer valid due to Easy Roam

I purchased a 30 day roaming package for my week trip in the U.S. I wanted more data, and thats why i purchased the 30day option. I am back in Canada, and am unable to use my regular data plan it seems. Anything that uses data is not working unless I am at home in Wifi. Imessage, gps, nothing. How can i fix this? I just want to be back on my regular plan I normally would use. Can i deactivate the roaming package?
Photo of Kayleigh Wilson

Kayleigh Wilson

  • 70 Points

Posted 10 months ago

  • 1
Photo of Paul Deschamps

Paul Deschamps, Mobile Master

  • 199,580 Points 100k badge 2x thumb
Hi Keighley, try turning the phone off and then back on again and/or toggling your airplane mode on and off. You should also turn off your roaming data button in your Data settings as well.
(Edited)

This conversation is no longer open for comments or replies.