Turn on data Galaxy S2

  • 1
  • Question
  • Updated 4 years ago
  • Answered
I have been using my phone without a data plan, and have now moved up to the $37.00 plan that includes 150mb of data. I have tried everything I could find on turning data on. Settings, More Settings, Mobile networks, green checks by Mobile Data and Data roaming, but when I am away from my wifi the phone said No signal found for mobile networks and this is at a number of locations. What am I missing?
Photo of Kevin Bryden

Kevin Bryden

  • 70 Points

Posted 4 years ago

  • 1
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
Do you have your data blocked by Koodo?
Photo of Camilo_A

Camilo_A

  • 31,746 Points 20k badge 2x thumb
Check your account on Self Serve, under Add-ons, check if you have the DATA BLOCK, if it is there, remove it from account.

You can also check the APN settings on your cellphone to see if those are the correct ones, check the link: http://help.koodomobile.com/plans-add...

If still not working, try to get in contact with Tech Support from a different phone for some troubleshooting...

This conversation is no longer open for comments or replies.