This is koodo customer service?

  • 1
  • Question
  • Updated 12 months ago
  • Answered
I am tired of being charged by Koodo for services that were never used or rendered.  I ordered the roaming package for Europe in March and had no single in London for 1 week!  No reply.  I now got charged $5 for Data in the US when my DATA usage (from Koodo) shows 0MB.  This is customer service?
Photo of TorontoMan

TorontoMan

  • 100 Points 100 badge 2x thumb
  • pissed off

Posted 12 months ago

  • 1
Photo of Goran

Goran, Mobile Master

  • 90,800 Points 50k badge 2x thumb
Did you enable international voice and data roaming before going to Europe? Restart your phone? Pull out and put back in your sim card? Enable automatic network selection? Enable roaming on your phone? Or check manual network selection to see which networks were available and try different ones?

It's possible that a few KB was used somehow and koodo starts charging at the first KB and it probably rounded down to 0MB.
Photo of TorontoMan

TorontoMan

  • 100 Points 100 badge 2x thumb
I am not new to mobiles or roaming.  Of course, I enabled before going to Europe. And I promptly disabled when I got  back.  How is even a few KB possible when data roaming is turned off?  Isn't that what Koodo and all other carriers recommend?  I have NEVER paid roaming charges on Bell and Rogers?  What makes Koodo special?
Photo of Allan

Allan, Mobile Master

  • 56,376 Points 50k badge 2x thumb
Are you saying you enabled roaming on your phone, added the $0 international voice and data roaming add-ons via self serve, or both?
Photo of David

David, Mobile Master

  • 89,190 Points 50k badge 2x thumb
A $5 charge could also be for sending a text while in the USA.
Photo of Goran

Goran, Mobile Master

  • 90,800 Points 50k badge 2x thumb
If it didn't work at all you can always try contacting customer support via Facebook messenger or DM via Twitter to get it reimbursed maybe if you had zero usage from it not working and you can report it didn't so it can be looked into if it was some sort of system or agreement issue. You said you enabled and disabled. Did you try any of the troubleshooting methods I gave or anything else as well?

Are you sure that it says for US data roaming on page 3 of your detailed bill?