the wifi on my brand new s4 wont turn on !

  • 1
  • Question
  • Updated 4 years ago
  • Answered
my brand new galaxy s4 wont connect to wifi! ever since i got the s4 about a week and a half ago it wont connect to wifi and a security notice appears when i try to turn the wifi on. the notice says "your device's security has blocked an action that is not permitted. no further action is required ." . i have tried to change the security settings and fix things but nothing that i do works . does anyone know how to fix this?
Photo of James Keddy

James Keddy

  • 90 Points 75 badge 2x thumb

Posted 4 years ago

  • 1
Photo of Matthew Sider

Matthew Sider

  • 2,432 Points 2k badge 2x thumb
Tray a master reset
Photo of James Keddy

James Keddy

  • 90 Points 75 badge 2x thumb
i already have
Photo of Angelea Leaming

Angelea Leaming

  • 964 Points 500 badge 2x thumb
Call koodo and ask them if there is some kind of block on it, I don't think there is any kind that you can but it may be a manufactures error or problem so you may need a new phone, you should go back to the store you got the phone from and explain the problem, they should be able to get you a free replacement.
Photo of Dennis

Dennis, Mobile Master

  • 178,354 Points 100k badge 2x thumb
If it is within the 15 day return period, BRING IT BACK. Then get another phone (similar or otherwise)
Photo of rikkster

rikkster, Mobile Master

  • 66,412 Points 50k badge 2x thumb
Check your phone for an update. Settings > More > About device > Software updates - tap Update. If no updates are available, please read on.

The only 'fix' I can think of (other than returning the device where purchased) is to downgrade from your current firmware version to an earlier version in order to regain functionality of Wi-Fi. Older firmware versions can be installed using Odin (a firmware flashing utility) and SamMobile, which is a database of current and older Samsung firmware images for many Samsung smartphones.

Your S4 is likely running Android version 4.4.2, you have the option of downgrading to an earlier version of 4.4.2, the earliest version of 4.4.2 is dated March 2014 and the most recent is dated May 2014.

You can verify which firmware version you have by going to Settings > More > Scroll to and tap About device and look under Baseband version and compare the string of alphanumeric text with the baseband versions under the PDA column in SamMobile. (If necessary, click on images below to see them better).

The model number of your S4 is SGH-i337M, you'll need the model number when performing a firmware search in SamMobile.

Note: You will have to register with SamMobile in order to download firmware. Registration is free and so is the firmware download.


If downgrading to an earlier version of 4.4.2 still doesn't resolve the problem, you can downgrade to version 4.3 - the Telus variant will work perfectly.

Odin link
Photo of James Keddy

James Keddy

  • 90 Points 75 badge 2x thumb
thanks for all the feedback guys ! i called the store and they are getting me a new s4 as we speak . and i went to the store today and even they had no idea how to solve the problem, the phone is just defective !