Text messages won't send

  • 4
  • Question
  • Updated 6 months ago
  • Doesn't Need an Answer
Nexus 4 - Android is up to date. Removed SIM card and re-started twice. Text messages still won't send. Any advice would be appreciated.
Photo of Henry

Henry

  • 140 Points 100 badge 2x thumb

Posted 3 years ago

  • 4
Photo of LairdC

LairdC

  • 5,164 Points 5k badge 2x thumb
Your data and voice working fine and only text that's giving you trouble?
Photo of Henry

Henry

  • 140 Points 100 badge 2x thumb
Voice is working fine. Data is working fine on wifi at home and when I am in a wifi spot i.e. Starbucks
Photo of Daniel Boileau

Daniel Boileau

  • 122 Points 100 badge 2x thumb
I have a new a5 have restarted 5 times. Sms wont send.. recieving intermittent msgs
Photo of Daniel Boileau

Daniel Boileau

  • 122 Points 100 badge 2x thumb
Data and calling works just sms.
Photo of Allan

Allan, Mobile Master

  • 56,306 Points 50k badge 2x thumb
Did you previously have an iPhone?
Photo of Daniel Boileau

Daniel Boileau

  • 122 Points 100 badge 2x thumb
I did a few mnths ago. It was fown for a couple hours that i know of. I changed settings from 3g to 4 g or vice versa.. not sure but its working now
Photo of Daniel Kim

Daniel Kim, Mobile Master

  • 34,736 Points 20k badge 2x thumb
Hi Henry, do you have 3g enabled on your phone? (WCDMA)
Photo of Henry

Henry

  • 140 Points 100 badge 2x thumb
No my 3G is not enabled. It used to be.
Photo of Henry

Henry

  • 140 Points 100 badge 2x thumb
No my 3G is not enabled. It used to be.
Photo of Robert

Robert, Mobile Master

  • 103,888 Points 100k badge 2x thumb
You need to enable it since it's needed to use basic phone functions (text call). You need to disable mobile data and not 3G. It's not the same thing :P
Photo of Henry

Henry

  • 140 Points 100 badge 2x thumb
I never turned 3G off, this must have changed with an upgrade. Do I need 3G when I am on wifi at home as well?
Photo of Yannick

Yannick

  • 43,978 Points 20k badge 2x thumb
Hi Henry, 3G must be on all the time for calls/SMS/MMS, even on WiFi :) Have a great day!