Text 30 not receiving texts in Italy

  • 1
  • Question
  • Updated 3 years ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members.

I tried many things but can't receive texts . help!
Photo of Doug Kloet

Doug Kloet

  • 80 Points 75 badge 2x thumb

Posted 3 years ago

  • 1
Photo of Robert

Robert, Mobile Master

  • 107,602 Points 100k badge 2x thumb
Do you have service in Italy? Is your cellphone connected to a provider?
(Edited)
Photo of Anna

Anna

  • 6,126 Points 5k badge 2x thumb
Hey Doug! If you do not have service at all, it means that you are missing some important add-ons that enable your device to connect to a foreign provider. Please visit us here http://koo.do/trvllng for the list of the add-ons you can add through your self-serve account http://koo.do/1jr0gGq. There are also a number of roaming packages you can choose from if you intend to use your device in Italy. If you haven't added them yet, you can find them here http://koo.do/trvllng, and they can also be added from your self-serve! Please let us know if everything works out :)
Photo of Doug Kloet

Doug Kloet

  • 80 Points 75 badge 2x thumb
On September 26 at 11:13am i received a text from Koodo welcoming me to Italy and reiterating the international text add on that i purchased. I'm paying for it. Why doesn't it work.
Photo of Anna

Anna

  • 6,126 Points 5k badge 2x thumb
It's possible that you are missing one of the two free features that will enable your device to work properly in Italy. Can you please check that you have both the Pay Per Use Intl Long Distance add-on and the International Voice Roaming add-on through your self-serve? That should fix your issue. Keep us posted :)
Photo of Yannick

Yannick

  • 44,018 Points 20k badge 2x thumb
Hi Doug, are you still having issues with text messages or is it working now? If you are still experiencing issues, the first step is always to power cycle your phone. If it doesn't help, can you check if your phone is set to Automatic Roaming? We have very helpful emulators on our website if you can't find it on your phone http://koo.do/Jhd0pw :) If Automatic Roaming is enabled and it doesn't work, try a manual search in "Network mode". Keep us posted! Buon viaggio!

This conversation is no longer open for comments or replies.