Sony Xperia P Android 4.0.4 can't send/receive pictures

  • Question
  • Updated 2 years ago
  • Answered
Hi there!

Been having a bit of trouble with getting my phone up and running lately.. I can now use the data network to browse online, but I for some reason cannot receive or send pictures. All I get are either a message stating, "Message not downloaded," or, "Queued for Sending" and it never sends..

I set up an APN as follows:

APN Name: KoodoSP
APN: sp.koodo.com
Proxy server: 74.49.0.18
Port: 80
Username:
Password:
Server:
MMSC: http: //aliasredirect.net/proxy/koodo/mmsc
Proxy server: 74.49.0.18
Port: 80
MCC : 302
MNC : 220
APN type :

I also tried setting up an additional "Koodo MMS ALLOWED" APN with all the same fields except the APN type was "mms". This caused me to be unable to connect online though..

My question I guess is whether or not there is a block on my account from sending multimedia over the network; being as my phone is supposed to be able to send/receive and I have an APN set..

Any and all help is greatly appreciated!!
Photo of Ryan Drescher

Ryan Drescher

  • 70 Points

Posted 2 years ago

  • 1
Photo of Paul Deschamps

Paul Deschamps, Mobile Master

  • 134,042 Points 100k badge 2x thumb
When you set up the APN that you have posted in your question make sure you save it & erase all the other APNs that could be showing After its set up while the phone is on take out the Battery & SIM Card for a minute or so then replace them & try it agin
Your phone is unlocked to work on Any provider right?
Photo of Starfox

Starfox

  • 5,678 Points 5k badge 2x thumb
I hope this isn't one of those situations where the unlocked phone just flat out won't work for picture msgs on Koodo. It's rare that an unlocked phone won't be able to use certain functions.
Photo of -

-

  • 730 Points 500 badge 2x thumb
Try this... This is what it looks like by default on my Stock Koodo GS3.

Name: Koodo SP

APN: sp.koodo.com

Proxy: Not Set

Port: Not Set

Username: Not Set

Password: Not Set

Server: Not Set

MMSC: http://aliasredirect.net/proxy/koodo/...

MMS Port: 80

MNC: 302

MNC: 220

Authentication type: None

APN Type: internet+mms

APN Protocol: IPv4

Bearer: Unspecified

Enter in what you can, I know some devices don't have all the fields.
What I noticed with your configuration is that you put in Port 80. And try APN type: internet+mms. The specified APN configuration by Koodo should work but this was how my phone is set up since day one so it can't hurt to give it a try.
Photo of Paul Deschamps

Paul Deschamps, Mobile Master

  • 133,806 Points 100k badge 2x thumb
How are you running that configuration without the proxy and port & getting Internet? when I erase those it disconnects the Internet and can only send picture messages.
Photo of -

-

  • 730 Points 500 badge 2x thumb
Yes that's how my Koodo GS3 is factory set, never touched the settings and my internet and MMS work perfectly.
Photo of jakeJ

jake

  • 60 Points
I updated my lg optimus black and can't either. I thought it wanted me to turn on data. I like some of the new features but this not being able to turn off background data is a real pain. I think lg should let us pick the android version we want!