Something about iMessage

  • 1
  • Question
  • Updated 5 months ago
  • Answered
Hi Koodo,

I am confusing that does the carrier (like you) charge for everytime user turn off the iMessage and reopen it (activate it)?
Is this activitiation free?
Photo of Ethan  Xu

Ethan Xu

  • 80 Points 75 badge 2x thumb

Posted 3 years ago

  • 1
Photo of Robert

Robert, Mobile Master

  • 101,040 Points 100k badge 2x thumb
No Koodo does not charge for activating and deactivating iMessage. Why do you ask?
Photo of Ahmad


  • 96,062 Points 50k badge 2x thumb
All these years of owning iPhones Robert and you still don't know that there's an initial 'activation' process for iMessage? :P That's why he's asking. He thinks every time he turns iMessage off and on that there is a charge for this
Photo of Ethan  Xu

Ethan Xu

  • 80 Points 75 badge 2x thumb
Yeah, I mean the initial activation.
Photo of David

David, Mobile Master

  • 83,290 Points 50k badge 2x thumb
No, there is no specific charge for activating Messages (formerly known as iMessage). However the application does expect ready access to data (either cellular or Wifi) to send messages.
Photo of Mayumi

Mayumi, Mobile Master

  • 111,050 Points 100k badge 2x thumb
iMessage need a data or wifi connection.
If you use it a lot with mobile data and went over your limit, you will get charge for data overage.
You can turn off iMessage and use regular text when wifi is not available to limit data usage.
Photo of Marie Trepanier

Marie Trepanier

  • 70 Points
Hi There
i just returned from a trip to Asia(where i bought different foreign sim cards). I am now back to Canada. I have put back my Koodo SIM card in the phone. My i-message from  i phone to iphone is no longer working unless I am on wifi. It won't work if I am using only my wireless data plan . I get the message "Cannot Send Message imessage needs to be enabled to send this message". I have checked my settings and imessage is enabled. Never had that before, I don't know what to try next!
Photo of Cory


  • 10,442 Points 10k badge 2x thumb
I think iMessage is probably still connected to the phone number of your previous SIM card (foreign card). You may have to go back into iMessage settings and disable it, and enable/activate your current Koodo number.
Photo of Timo Tuokkola

Timo Tuokkola, Mobile Master

  • 136,982 Points 100k badge 2x thumb
You may actually need to disable it, restart the phone, and then enable it.
Photo of Marie Trepanier

Marie Trepanier

  • 70 Points
my sim card oversea was only for data ie I couldn't make phone calls. Just now 1.I have disabled i message.2.Turned off my phone, 3.restarted my phone it and i still getting the message " Cannot Send Message iMessage needs to be enabled to send this message"
Photo of Janet Klein

Janet Klein

  • 60 Points
My last thought is to start a fresh thread with whomever you are contacting and enter their number manually. This must be frustrating for you. I went through the same type of thing in Maui last year when I could not send an SMS message with imessage enabled. I could use imessage when on the internet but when I was out and about with no data (too expensive) it would not send as SMS. I finally got it to work by deleting the thread and starting fresh by entering the phone number manually.