Slower then normal data speeds on Nexus 4

  • 2
  • Question
  • Updated 5 years ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members.

Not sure what is going on here but I am starting to get annoyed. I have just gotten this phone a day ago and so far have had nothing but issues with it. First it was intermittent data connection. Now it seems that since I first noticed the issue around 9:40 this evening, and I am going to post pics of the data speeds that I have found using the Speedtest.net app for Android, I am getting around 0.65 MBPS download and around 0.30 MBPS upload when I should be getting about 15 MBPS down and 1.2 MBPS up.







As you can see in the pics above, I have good reception and am connected to the network using my cellular data. Also in the second pic I have valid IP addresses, and in the third pic, I tried this test three times with the closest server being North Bay, Ontario. The time gaps in between the first to second test and second to last test are me first turning the airplane mode off and then on again and then the second gap are me turning phone off, removing and replacing the SIM, and then turning phone on again.

I am seriously starting to regret my decision to get this phone. Should I bring this phone back to Koodo and do an exchange to see if that fixes the solution or should I just hold out and see if its a simple issue with the whole network?
Photo of Alcide Robidoux

Alcide Robidoux

  • 1,994 Points 1k badge 2x thumb
  • frustrated

Posted 5 years ago

  • 2
Photo of Chris Petersens

Chris Petersens

  • 47,266 Points 20k badge 2x thumb
While this is a thread about the same issue on At&T you might find the solution needed to be the same. Unless you already covered that.
Photo of Alcide Robidoux

Alcide Robidoux

  • 1,994 Points 1k badge 2x thumb
No offence meant Chris, but as I am not on AT&T and am on koodo, I am not going to know to check forums from an american site for an issue that I am having on a Canadian provider. Can you provide a link to this post from at&t so I can see what their solution was?
Photo of Chris Petersens

Chris Petersens

  • 47,266 Points 20k badge 2x thumb
None taken. It's my fault. Here is the link. http://forum.xda-developers.com/showt...
Photo of Alcide Robidoux

Alcide Robidoux

  • 1,994 Points 1k badge 2x thumb
Thanks Chris. :) I will see if this solves anything.
Photo of Alcide Robidoux

Alcide Robidoux

  • 1,994 Points 1k badge 2x thumb
So as I can't edit my original post. I have now tried to send a text and it is just saying SENDING and not actually sending. I have also tried to call out and it is not working at all... Really getting ticked off right now...
Photo of Paul Deschamps

Paul Deschamps, Mobile Master

  • 203,250 Points 100k badge 2x thumb
I've had the Nexus 4 for a month or so now and never had a single issue with it. Have you upgraded to the newest version of Android 4.3 since getting the phone?
When you say that your text isn't working are you using the stock texting app or a 3rd party app you downloaded from the playstore?
Photo of Alcide Robidoux

Alcide Robidoux

  • 1,994 Points 1k badge 2x thumb
I was on the latest update, and was using the stock texting app.
Photo of MykeC

MykeC

  • 20,174 Points 20k badge 2x thumb
Hey Alcide, with slow data speeds, network congestion can also be a factor as well, but this is usually temporary. If you find that this is a constant issue, give our Technical Support a call (*611 Option 6) and they can do additional troubleshooting and log a network ticket for further investigation.

________________________

If you see a good answer, give it a star.

This conversation is no longer open for comments or replies.