Site keeps going french.

  • 2
  • Question
  • Updated 4 years ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: *611 or 1-866-995-6636 mentions

The site keeps changing to the french version. what gives? I've tried everything, changing the fr in the URL, googling it and using the link and it still turns up french, even the forum i had to delete fr at the end of the url after it brought me to the french forum, at the start i select english and ontario when prompted.
Photo of kyle verbrugge

kyle verbrugge

  • 120 Points 100 badge 2x thumb

Posted 4 years ago

  • 2
Photo of Dennis

Dennis, Mobile Master

  • 178,190 Points 100k badge 2x thumb
Clear your cache and cookies and try again
Photo of quasarito


  • 9,738 Points 5k badge 2x thumb
If you're talking about the Self-Serve site, your Koodo profile may have been set to French when you signed up, so when you log in it will take your language settings from your profile. Give customer service a call (*611) and have them change your language setting.
Photo of Santeana


  • 70 Points
I have the same issue. I click on my favourite in my browser and it takes me to my login page for self-serve. I login. The page is in English. I click on, say, phones. Page changes to French.
So I did as was mentioned above and cleared my browser history, cache, cookies, etc. Click on my KOODO link, login, and of course, it's English. I click on the KOODO Mobile splash at the top left of the page and it loads in French! There is no reason for this. Also, it does it both when I login from my laptop, or I use my phone's browser.
Photo of Mayumi

Mayumi, Mobile Master

  • 111,356 Points 100k badge 2x thumb
Call customer service *611 option 6 for technical support.
They will help you to fix it :)

This conversation is no longer open for comments or replies.