Sim card error

  • 3
  • Question
  • Updated 1 year ago
  • Answered
My phone says it doesn't have a sim card in it when it does, I have restarted, taken the sim card in and out, charged it and plugged into my computer and nothing has worked, help please!
Photo of Abbie Humphreys

Abbie Humphreys

  • 90 Points 75 badge 2x thumb

Posted 5 years ago

  • 3
Photo of Myke

Myke

  • 45,090 Points 20k badge 2x thumb
Make sure you're putting the sim card in correctly. If it's still not reading it, then it's an issue with the phone. If it's under warranty, send it in for repair.
Photo of Dennis

Dennis, Mobile Master

  • 196,100 Points 100k badge 2x thumb
I put my sim card in backwards one time. Took me forever to find out that was the problem lol
Photo of Joe Hunt

Joe Hunt

  • 70 Points
SIM card problem.It was the first time i put one in,so i pop it outta the to make it smaller when i shouldnt have,Then i tried putting it back together which was hard to do but i finally did it,but the card must be in wrong.
Photo of Allan

Allan, Mobile Master

  • 62,392 Points 50k badge 2x thumb
Firstly I would suggest making a new thread instead of reviving old ones. Secondly, if the sim card isn't working after you put it back together you may have to get another one. The Koodo store may give you one for free if you explain the situation. As well ask them to pop it out for you so you don't accidentally make the same mistake.
Photo of Zaphod Beeblebrox

Zaphod Beeblebrox

  • 50,808 Points 50k badge 2x thumb
If possible, try to put the SIM card in another phone. If you get the same result, the SIM card is fried.
Photo of John Lee

John Lee

  • 36,724 Points 20k badge 2x thumb
If the SIM card is faulty, you can go pick up a new one at Koodo. They are $10.
Photo of Daniel Kim

Daniel Kim, Mobile Master

  • 34,736 Points 20k badge 2x thumb
prepaid sims are $20 btw and postpaid like john said is 10
Im having the same issue, new sim card, worked for a couple hours, now saying no sim card, have also tried removing and replacing, shutting down and back on. Nothing :(