Shock free data doesn't work

  • 1
  • Question
  • Updated 1 year ago
  • (Edited)
i have been with Koodo for about 6 months now and I love it. I love Koodo, I'd recommend to everyone I know. I had the $90 for 5GB plan first and I'm pretty sure it was Shock Free Data but I hardly ever went over my data. Just recently I've changed my plan to $75 dollars shock free data and I actually went over my data by $10 and then it says $15... then I realized that my shock free data doesn't work. I'm wondering why ?
Photo of Angela Lee

Angela Lee

  • 70 Points
  • upset

Posted 1 year ago

  • 1
Photo of Goran

Goran, Mobile Master

  • 90,490 Points 50k badge 2x thumb
What happened? Have you not gotten notifications or stop data? If it's enabled it's supposed to work. First make sure that you have a an with shock free data. It was not retroactively added to plans that exist before the lineup of shock free data plans Koodo has i.e. grandfathered plans. After that go to "view usage" in self-serve and then under your data usage chart select "change data alerts". And make sure that the option is checkmarked. If it is, I can only give generic flowchart answers from here on out even more so and it would be helpful to know exactly what isn't working but it boils down to if it's all enabled and you never got the warnings or the data stopped alerts you'll then need to get a Koodo Rep to look at your account by sending a private message to Koodo via Facebook or DM via Twitter. Let us know!
Photo of Nadim Khimani

Nadim Khimani

  • 238 Points 100 badge 2x thumb
In the meantime use this guide so that at least your phone will block the data overage:

(For Android)

you can easily turn off data usage after it hits a certain point.

To do this go to settings - data usage - billing cycle - set your billing date and data limit and your current data usage from Koodo self serve. Then make sure the "auto-disconnect from network when usage limit reached" slider is on.