Self Serve not working!!!

  • 1
  • Question
  • Updated 4 years ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: SS App mentions

I just registered for self serve, and all seemed to be going normally I got the email with the link and validated my email account. The problem is there is no self serve access. I cannot see my bill, features or anything. The only aspect of my account that shows up is the settings such as email, password, secret question... Everytime I click the self serve button it just brings me back to that page. I have tried logging on with 3 different browsers, tried downloading the app and using my phone to log in, and it is always the same result. Did I do something wrong? or is the selfserve feature not working? I am not a stranger to online mobile site, but koodoo is new to me and so far it is very confusing and frustrating. Virgin mobile was so much more user friendly. If it doesn't get fixed soon I'll have to call koodoo(trying to avoid this) cause I really need to check my charges.

Thanks!
Photo of Dheny Rivas

Dheny Rivas

  • 70 Points

Posted 4 years ago

  • 1
Photo of Timo Tuokkola

Timo Tuokkola, Mobile Master

  • 139,992 Points 100k badge 2x thumb
Official Response
The system will only allow one email address to be registered as the account owner. The first login profile to be created is assigned this role. Any errors which occur during the creation of this first profile (including a typo in the email address entered by a store rep or a confirmation email that doesn't arrive) result in an incomplete account owner profile that cannot be logged into. Any subsequent attempts by the user to create another profile result in the creation of manager profiles which must be approved by the owner before they can access the account.