Self Serve not fully functional

  • 1
  • Question
  • Updated 3 years ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members.

In short: The self serve seems to be broken and I can't add a us roaming package to my account.

I'm trying to add a US Roaming package to my account. However, when I log into self serve, the "phone services" tab times out before loading. I've tried Firefox, Chrome, Firefox private mode and my android phone.

I've also tried texting Koodo to add the package but I haven't received a response.
Photo of Theace oface

Theace oface

  • 70 Points

Posted 3 years ago

  • 1
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
Give customer service a call, they will add the program to your account. Just make sure to tell them self serve isn't working for you and they'll waive the service fee. *611 from your phone.
(Edited)
Photo of Robert

Robert, Mobile Master

  • 107,634 Points 100k badge 2x thumb
Also make sure the service isn't added already because you texted to activate it. Because usually if you texted the good number, it should have worked!
Photo of BobTheElectrician

BobTheElectrician

  • 67,714 Points 50k badge 2x thumb
More than a few reports on English and French side of community that no confirming texts were received after ordering the add-on that way. As Robert says, check your self-serve to verify it's been added. If you don't see it, call *611 as Chad advises.

This conversation is no longer open for comments or replies.