Searching for a signal

  • 1
  • Question
  • Updated 8 months ago
I recently switched companies from Bell to Koodo after seeing the significantly lower montly costs and great reviews. I received my phone a little over a week ago, but I still continue to have problems with getting sell service, with the top left corner of the phone showing "Searching..." more often than it should be. My partner, who lives with me, has been with Koodo for awhile now, and she never has any problems getting service. I'm wondering if I'm having trouble getting service because my account with Koodo is still recently new (AKA. Can I expect this issue to be resolved within the next few days), or should I be concerned that there may be osmething wrong with the phone a received and I should be contacting the company. 
Just for a few additional details, I bought the iPhone 7, and purchased it online and activated it on September 18th. Any help would be greatly appreciated! I'm pretty much wondering if this is something I should be concerned about, or if it should resolve itself over the next couple of days... Thanks!
Photo of Emily Hale

Emily Hale

  • 110 Points 100 badge 2x thumb
  • Frusterated

Posted 8 months ago

  • 1
Photo of Goran

Goran, Mobile Master

  • 90,032 Points 50k badge 2x thumb
Did you port over or start a brand new line with new number?
Photo of titaniumtux

titaniumtux

  • 12,912 Points 10k badge 2x thumb

Mind providing a postal code or city where you're using the Koodo cell service? Which Koodo phone did you take? Usually Bell/TELUS/Virgin/Koodo should get mostly the same cell reception.

Link to CellMapper.

Doubt you'll get any chance in cell reception in the coming days just because your Koodo account is new.

Photo of Goran

Goran, Mobile Master

  • 90,032 Points 50k badge 2x thumb
So September 18 is when you ported over? It's possible that there is some sort of backend issue related to the porting process. You can send a private message to Koodo via Facebook Messenger or DM via Twitter to see if there are issues related to porting.
Photo of titaniumtux

titaniumtux

  • 12,912 Points 10k badge 2x thumb
Wireless to wireless porting takes minutes, doubt the number porting from Bell Mobility would be the issue...
Photo of Emily Hale

Emily Hale

  • 110 Points 100 badge 2x thumb
We're in the Annapolis Valley in Nova Scotia, but I don't think it has anything to do with the cell reception itself, cause someone in the same house as me has no issues and they're with koodo. It seems to be the phone not being able to connect to the available reception....
Photo of Goran

Goran, Mobile Master

  • 90,032 Points 50k badge 2x thumb
This is a perfect opportunity then since you have two people with koodo: swap Sims and see if the problem follows or not.

As for porting, people have reported not being fully ported over even 48 hours after porting. It can happen though not often.
(Edited)
Photo of Dinh

Dinh, Mobile Master

  • 32,346 Points 20k badge 2x thumb
There shouldn't be any discrimination against new account.

I would suggest you reset the network settings to let the phone reload network and see if it is better (Settings --> general --> Reset --> Reset Network settings). You might have to reenter password for wifi again after that.
Photo of Ry

Ry

  • 5,552 Points 5k badge 2x thumb
Constant searching in an area with known good coverage sounds like a defective phone.