Samsung S4 Battery Life

  • 1
  • Question
  • Updated 5 years ago
  • Answered
Samsung Galaxy S4, only 2 months old, and not running on LTE network, still the battery drains within 12 hours. Already tried battery saver apps, no improvement. Turned on battery save option on phone. No GPS, No Gestures are turned on. Should i take it to the store for repair?
Photo of Shuvro .

Shuvro .

  • 86 Points 75 badge 2x thumb

Posted 5 years ago

  • 1
Photo of Humberto Giambrone

Humberto Giambrone

  • 4,900 Points 4k badge 2x thumb
It could be what's running in the background, perhaps a battery hogging app or wakelock that may be keeping your phone active when supposedly asleep. You could check the battery in the settings menu for an idea. Additionally, there are a few different apps that could help identify the issue (especially with wakelocks):

A couple of recommendations:
(Check if your phone is going into 'Deep Sleep'): CPU Spy Plus: https://play.google.com/store/apps/de...

(Detailed App info): GSam Battery Monitor: https://play.google.com/store/apps/de...

(Wakelock, CPU, Process info): BetterBatteryStats: https://play.google.com/store/apps/de... (Some elements requires Root Access, but most of the key info doesn't)

I'm sure others, especially anybody with a S4, will chime in with other ideas. I don't have an S4 myself.
Photo of Jonathan I

Jonathan I, Mobile Master

  • 114,344 Points 100k badge 2x thumb
In addition what's been mentioned, try this:

Turn off WiFi, GPS, Bluetooth, data, etc. when you're not using them.

Hold down the home button and clear all the apps running in the background.

Hold down home again and select the pie graph symbol. Go to the RAm tab and hit clear memory. It will clear out any apps storing things in the cache on the phone.

Last thing:

Settings > Developer Options > Limit background processes (near the very bottom). Set to 4 or less. See if that improves anything. I know it did for my S III.
Photo of Paul Deschamps

Paul Deschamps, Mobile Master

  • 199,584 Points 100k badge 2x thumb
It's gotta be an app or something you have on because I get amazing battery life on my Galaxy S4. Games take the most power out of anything particularly graphically instance games like real racing 3 or wild blood stuff like that. I can play games for 6-7 hrs continously non stop and if I'm browsing the Web and watching videos more up to usually 8hrs of non stop use.

When your battery is at 5% go to your battery stats in your settings menu and click on the display reading that will show your screen on time and let us know that time.

IMO battery saver apps do nothing but take more battery as they only do things you can do manually anyways. You can try going into your settings and under my device click power saving then turn it on and check off all the options including CPU limiting. Still let us know your screen on time at about 5% then I can tell you if it's normal.
Photo of Shuvro .

Shuvro .

  • 86 Points 75 badge 2x thumb
Thanks all for your replies. good suggestions. I narrow down the problem. last night i had full charge around 8 pm and turned off wifi and mobile data both, since then it's already passed 14 hrs and my battery is on 90% now. WOW. so it's definitely apps that data sync all the time behind the scene. Is there any way i can restrict any particular app not to use data while my phone screen is off? from my data usages, i noticed one app name PINGER (like viper/skype) is using most of the data. However pinger app itself doesn't have any option to turn off data while phone is on sleep type option. thanks again.
Photo of Paul Deschamps

Paul Deschamps, Mobile Master

  • 199,580 Points 100k badge 2x thumb
If the app your talking about is a video call or VOIP type app then for it to work properly you'll have to have it running in the background for when someone contacts you through it. If you only use it over wifi to initiate calls then you can go to your phones settings - data usage - then scroll down to that app in the list there and click on it - now again scroll to the bottom and you'll see restrict background data while on mobile data, check it off. Now it will only use wifi. That may help you in the case you do use that app only through wifi

This conversation is no longer open for comments or replies.