Samsung Galaxy S II X (screenshot not working)

  • 1
  • Question
  • Updated 5 years ago
  • Answered
Ok I just got the Galaxy S II X, I have tried everything mentioned in here to get a screen shot. I have tried third party apps they say not compatible. I did some research and my ASL (Android Screenshot Library) Is not a background running process could this be the problem?

Phone is a Koodo Phone
I did not root it. The Apps I tried were all NON Root Apps. :)

Phone is the SGH-T989D

Thanks in Advance for any Help.
Photo of David P.C

David P.C

  • 130 Points 100 badge 2x thumb

Posted 5 years ago

  • 1
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,644 Points 100k badge 2x thumb
It is a very tricky maneuver

Hover one finger over the home key and another finger over the power button.

Take a deep breath count to three and press both at the same time and hold it.

Let us know.
Photo of Paul Deschamps

Paul Deschamps, Mobile Master

  • 193,200 Points 100k badge 2x thumb
Use the power from within young Jedi lol ;-)
Photo of David P.C

David P.C

  • 130 Points 100 badge 2x thumb
OMG Tried All Day.... and nothing haha

The Hovering and Pressing Same time Helped and Worked... Thank You A Ton!

Thanks Chad!
Photo of Rolando Monte

Rolando Monte

  • 60 Points
I have been on at least 50 sites trying to figure this out. I have tried and tried and tried. The hovering and hold technique worked for me just fine!!! OMG FINALLY GOT IT TO WORK!! I was about to return my phone!

This conversation is no longer open for comments or replies.