Samsung S6 Late/ dont get facebook messenger or gmail notifications

  • 1
  • Question
  • Updated 1 year ago
  • Answered
Samsung S6, all current updates done.

Recently started having issues not getting Facebook Messenger notifications at all until I open the app. When I open the app, it quickly says "Waiting to connect" for a few seconds, then says "Connected" and then any notifications pop up, in some cases from hours before. Have deleted both the Messenger app, and facebook, re downloaded them to the phone, restarted the phone, SIM pull, etc all the basic stuff with nothing making a change at this point.

I have also had Gmail issues for about the past 2 months. I dont seem to get a notification until I have a second email (at which point the first may be an hour or more old)or it seems if I get an email while on Wi-Fi I NORMALLY get the notification right away. I also get a notification on my phone the second I open Gmail on my desktop.

Looking for any possible solutions. Have looked through my settings, nothing glaring to me that seems off. I am in SW Ontario with no connectivity issues to speak of.
Photo of Kyle Waters

Kyle Waters

  • 90 Points 75 badge 2x thumb

Posted 1 year ago

  • 1
Photo of Dennis

Dennis, Mobile Master

  • 196,120 Points 100k badge 2x thumb
Do you have do not disturb mode on?  How about powersaving mode?  Try turning these off and see if it makes a difference
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,988 Points 100k badge 2x thumb
Do you have background data turned off for these apps?
Photo of Kyle Waters

Kyle Waters

  • 90 Points 75 badge 2x thumb
Dennis, I do not have DND mode on, or powersaving mode on. I did have powersave mode on, but did not see any change once turning it off. It is still currently off.

Chad, not restricting background data on those apps on my phone
Photo of Dennis

Dennis, Mobile Master

  • 196,120 Points 100k badge 2x thumb
Does this happen on wifi and on mobile data?
Photo of Kyle Waters

Kyle Waters

  • 90 Points 75 badge 2x thumb
Yes, it happens on wifi and mobile data, have even turned my mobile data off while at home on wifi to test it.
Photo of Dennis

Dennis, Mobile Master

  • 196,120 Points 100k badge 2x thumb
I think I am out of ideas.  I would do a factory reset to fix it.  Unless anyone else has any ideas?
Photo of Gabriel

Gabriel, Employee

  • 100 Points 100 badge 2x thumb
Hey Kyle! :) Have you tried to clear cache and clear data of the app? You can do this by following these steps:

Go to Applications >> settings >> Applications >> Application manager >> Slide to the right to see the '' All '' option >> Select Application Facebook >>  make clear cache and clear data 'then' Force shutdown '.

Hope this helps!