Samsung S5 neo other party hears their own vioice as an echo

  • 1
  • Question
  • Updated 3 months ago
  • Answered
When our phone is on "speaker phone" there are no echos at either end.   Off speaker phone the other party hears themselves as an echo,  no echo on our end.

We have had the new phone for a few months and this problem has just cropped up.

Any help would be greatly appreciated.
Photo of Zana Nesbitt

Zana Nesbitt

  • 370 Points 250 badge 2x thumb

Posted 1 year ago

  • 1
Photo of Zana Nesbitt

Zana Nesbitt

  • 370 Points 250 badge 2x thumb
I did several searches here without success before posting.    While waiting for a life saver to come along I went to the internet in general and found a suggestion to turn noise suppression off.   Unfortunately the thread was for a different android OS.

When looking for the NS off switch I came across the Hearing Aids switch that " Improve the sound quality of your device for use with hearing aids"   Which if may do slightly but it does create the echo for the other user when not on speaker phone.

For those that may want  to find or have forgotten where is switch is...      Android  6.0.1

1.  phone
2.  more
3.  settings
4.  more settings
5.  hearing aids
Photo of Daniel Kim

Daniel Kim, Mobile Master

  • 34,736 Points 20k badge 2x thumb
Cool, I'll keep that in mind. Great find Zana :)
Photo of Dave Stewart

Dave Stewart

  • 60 Points
that worked...thanks a million
Photo of Daniel Kim

Daniel Kim, Mobile Master

  • 34,736 Points 20k badge 2x thumb
Try going into your dialer app> press the three dots to go to settings>call> then scroll down and see if the noise reduction box is checked. If it's on try disabling it and test the call quality and vise versa. Hope that helps :)
Hi Daniel,
I am having the same problem. The person who talks to me said they get an echo voice and its hard to hear. 
its just new phone which i bought in store in the month of january2017. 
What can it be done?. I am not able to make calls to anyone.
Photo of Allan

Allan, Mobile Master

  • 56,506 Points 50k badge 2x thumb
Do you have your phone on speakerphone or are you using a bluetooth device that projects through a speaker?
Usually echoes occur when the mic on your phone is picking up the output of your device and puts it in an "echo" like fashion. Just try turning the volume down and see if that helps.
Photo of Mec Levillagois

Mec Levillagois

  • 60 Points
For 'Samsung S5 NEO' go on your 'S Voice' app (it's a light blue icone with a white microphone) Agree to the therms, then with that application go in the settings and turn off  the 'Auto Start speakerphone' and the 'Voice feedback'.
Photo of Allan

Allan, Mobile Master

  • 56,506 Points 50k badge 2x thumb
That only applies to when you make calls using the s voice app and the OP mentioned they had speakerphone off.
Also this thread is a few months old and has already been solved.