Samsung S4 "No Service"

  • 1
  • Question
  • Updated 3 years ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members.

Phone currently says "no service" so can't make or receive calls or texts.
Here is the history:
- I suspended service because my phone was lost (via SelfServe)
- I restarted service when my phone was find (via Self-Serve)
- the next day I got a message that my sim card was unregistered
- called Koodo and was told my sim card must be demagnetized and to go get new one
- went to Koodo booth, Got new sim card but it didn't show as registered either. Rep at the booth tried many things but now I have a phone with "no service." Was told I would need to send phone in for repair which, of course, could come at a significant cost.

I have tried accessing the service numerous times (via settings) but keep getting message "selected network (Koodo) unavailable." Have turned phone on and off as well.

Photo of Nancy Phair

Nancy Phair

  • 100 Points 100 badge 2x thumb

Posted 3 years ago

  • 1
Photo of Mathieu

Mathieu, Mobile Master

  • 60,788 Points 50k badge 2x thumb
Hi Nancy,

Try turning the phone off, removing the battery and the SIM card and leaving it for a minute. Put it back together and turn it on to see if you get service again.

If that does not get your service up and running again, try performing a factory restore on the device (Settings -> Accounts -> Backup and reset --> Factory data reset). Doing so will result in loss of all data on the phone, so make sure to back everything up before you do this.

If you are still having issues with it, try calling Koodo from another phone at 1 (866) 995-6636.

Hope this helps!

This conversation is no longer open for comments or replies.