Samsung Galaxy s4 not receiving messages on data

  • 1
  • Question
  • Updated 3 years ago
  • Answered
I have a Samsung galaxy s4. When I'm on wifi I receive all messages from all apps. When I'm not on wifi, turn data on, I only receive text messages. I don't receive Facebook messenger, what's app, viber, Skype, hangouts messages until I'm back on wifi. In settings I have background refresh turned on so the messages should be coming through.
Photo of Delia

Delia

  • 150 Points 100 badge 2x thumb

Posted 3 years ago

  • 1
Photo of Ahmad

Ahmad

  • 96,102 Points 50k badge 2x thumb
It sounds like you may have a data block on the account level. Log into self-serve and see if under your add-ons you have a data block. If so, you can modify your add-ons yourself to remove it from self-serve.
Photo of Delia

Delia

  • 150 Points 100 badge 2x thumb
Thank you for the suggestion Ahmad. I checked my add ons and I don't see anything about a data block.
Photo of Paul Deschamps

Paul Deschamps, Mobile Master

  • 199,438 Points 100k badge 2x thumb
What version of Android are you running on your S4 exactly?
Photo of Delia

Delia

  • 150 Points 100 badge 2x thumb
Paul.. 5.0.1
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,968 Points 100k badge 2x thumb

Pull down the notification shade and be sure mobile data AMD sync are turned on

In this example pic, data is on but sync isn't

If both are on open settings ... wireless and networks ... more... mobile networks.

Be sure "enable data" is checked

Also navigate to "Access Point Names"

be sure "Koodo.sp" is selected


In this example pic, data is on but sync isn't


(Edited)
Photo of Delia

Delia

  • 150 Points 100 badge 2x thumb
Hi Chad.. I took a screenshot of my pull down window and there is no data option. I go to settings to turn data on. For this screenshot i had data and wifi on. I have done all the other things you suggested, they were already checked how you suggested.
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,968 Points 100k badge 2x thumb
Navigate to "Access Point Names"

Create a new APN
Enter the settings below:

APN: sp.koodo.com
Proxy: 74.49.0.18
Port: 80
Username: leave blank
Password: leave blank
Server: leave blank
MMSC: http ://aliasredirect.net/proxy/koodo/mmsc
MMS Proxy server: 74.49.0.18
MMS Port: 80
MCC: 302
MNC: 220
Authentication type: No set
APN type: No set

When you're done tap the menu key and save this apn

Make sure it's then selected.
See if that helps.
Photo of Delia

Delia

  • 150 Points 100 badge 2x thumb
Hi Chad.. unfortunately that didn't work either. I tested it with Hangouts and Whatsapp and didn't get the messages until I was back on wifi.
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,968 Points 100k badge 2x thumb
Navigate to wireless and networks, data usage
Make sure a limit isn't in place.



Does your browser work?

I'm starting to think more and more Ahmad may be correct about a data block. If these settings are right then it's time to call tech support. It's free.
(Edited)

This conversation is no longer open for comments or replies.