Samsung galaxy ace 2x won't connect to wifi?

  • 1
  • Question
  • Updated 4 years ago
  • Answered
I've had my samsung galaxy ace 2x for about a year now. Recently, it has stopped connecting to my home wifi. It'll say that it's connected but I can't use applications that require wifi. It will work for some parts of the day and I will be able to use wifi but then it will stop working.

I've done a router reset, a factory reset on my phone, taking out the battery, forgetting the network, but sometimes when I enter the password to my wifi, it will say error authenticating. How do I fix this?
Photo of HaNnAh

HaNnAh

  • 80 Points 75 badge 2x thumb

Posted 4 years ago

  • 1
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,968 Points 100k badge 2x thumb
http://community.koodomobile.com/kood...

Try the link above.

Also I would urge you to upgrade your device. The Ace iix is an older single core device that while it's pretty, it's starting to get bogged down just from use.

There are some great new and wonderful options out on koodos line up and some can be had for very little out of pocket cash.

The Moto G is a quad core quick like a bunny android that blows the ace iix out of the water.it has a huge battery too! Only issue is it only has 8gb of storage and no SD card slot.

The Nokia Lumia 635 is an amazing Quad core windows phone will a solid foundation. It's fun and fits right in your hand. Has an SD card slot but no front facing camera for those who wish to selfie.

And the Blackberry Q5 is also a solid performer and has a physical keyboard.

All 3 are 150$

There's also some Alcatel models but I don't have any real world experience with those.

Any of them are a huge step up from the Ace IIx
Photo of HaNnAh

HaNnAh

  • 80 Points 75 badge 2x thumb
Still nothing. After a few tries my phone will connect, but I can't use my wifi
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,968 Points 100k badge 2x thumb
How old is your router? Have you ever updated the routers firmware?

Does your router have push button connections available?
Photo of rikkster

rikkster, Mobile Master

  • 67,084 Points 50k badge 2x thumb
The only other solution I can think of is to make your Ace 2x a preferred device using MAC address filtering by adding your phones' Wi-Fi MAC address to a preferred list of devices on your wireless router.

The Wi-Fi MAC address for the Ace 2x is found under Settings > About phone - tap Status and scroll down to Wi-Fi MAC address. You probably won't see anything there until you establish a Wi-Fi connection with the Ace 2x. You will have to temporarily disable the security settings on your router so that the Ace 2x is able to connect to your router and a Wi-Fi MAC address appears on your phone.

Go to the wireless security settings portion of your router by typing it's own IP address into whatever browser you use. The most common default IP addresses are 192.168.0.1 or 192.168.1.1 - the IP address is usually printed on a sticker on the router itself.

After you login to your router, look under the Wireless section and see if the router supports MAC address filtering. If it does, enter the Wi-Fi MAC address in the box provided and click save. Re-enable the security settings and reboot your router. If all goes as planned, your Ace 2x will always connect to Wi-Fi as soon as you're in range.

Or, instead of going through all of this, look into some of the devices Chad has suggested. Wi-Fi works right out of the box on all of the newer smartphones sold today. I have both the Moto G and Lumia 635 and I've had no issues with accessing Wi-Fi whatsoever.

This conversation is no longer open for comments or replies.