s4 connection issues

  • 1
  • Question
  • Updated 4 years ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: 1-866-995-6636

My galaxy s4 will keep losing service until I restart my phone and then it has full bars again. It will do this 3-4 times a day. Sometimes it will say I have service but my messages won't send and then half an hour later it will tell me I have no bars. I am running v. 4.4.2 and it says it is the latest version. I am getting frustrated as I am missing calls and texts. Does anyone have a solution?
Photo of Marcus Warnholz

Marcus Warnholz

  • 70 Points

Posted 4 years ago

  • 1
Photo of Yannick

Yannick

  • 44,018 Points 20k badge 2x thumb
Hi Marcus, you should go to a Koodo store and let a rep have a look at your phone. It might need to be sent for repairs: http://koo.do/JVO5Mk. You can find the closest store on this link: http://koo.do/locator123. If you live too far, you can contact us over the phone at 1-866-995-6636 from another phone, option #6 for technical support. Thank you!

________________________
If you see a good answer, give it a star.
Photo of Daniel Gunn

Daniel Gunn

  • 19,800 Points 10k badge 2x thumb
I think this may be a software related problem, there are a few people who have been having issues with reception since the 4.4.2 kitkat version came out for the S4.

You can definitely take it to the store and have it serviced, or you can do a factory reset as that tends to rectify the problem. Most people do not like having to reset their device but that's what I'd suggest.

This conversation is no longer open for comments or replies.