S4 unregistered sim

  • 2
  • Question
  • Updated 3 years ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: 1-866-995-6636

My friend borrowed my samsung s4 device while overseas and unlocked it to use over there. However, ever since he got back, whenever I put in my sim it gives me the error of unregistered sim and does not give me cellular coverage. The sim is working fine on another phone.
I tried manually looking up the mobile networks from the connection and found Koodo listed there, however it gives me an error "Unable to connect to Koodo".

System update does not work either.

I would appreciate any help that would get the sim working on my current S4 without having to change the phone. (my friend says the overseas worked perfectly fine on the device, the error is with the Koodo sim in Canada). The device was issued by Koodo as well.
Photo of Ali Hassan

Ali Hassan

  • 130 Points 100 badge 2x thumb

Posted 3 years ago

  • 2
Photo of Jonathan I

Jonathan I, Mobile Master

  • 114,344 Points 100k badge 2x thumb
Check the IMEI of your phone at this website:


It could be blacklisted in North America.
Photo of Ali Hassan

Ali Hassan

  • 130 Points 100 badge 2x thumb
If the IMEI is not showing up, does it mean that it may be corrupted and that is the issue?
Photo of Ali Hassan

Ali Hassan

  • 130 Points 100 badge 2x thumb
I used the number on the phone beneath the battery. It says no record of anything found.
When I try to find the iemi through the hash code.. it says eimi : /08
Photo of Chad Burr

Chad Burr, Mobile Master

  • 203,644 Points 100k badge 2x thumb
First thing to try is powering down your device and removing the sim card and, if possible, the battery Wait a minute and then reinstall the sim and battery. Restart your device.

Didn't work?

Check and be sure you're not in Airplane or Flight Mode.

Still not working?

Navigate to your settings and mobile network settings.

Be sure that:
Network Selection is set to Automatic
USE 2G Only or USE GSM ONLY isn't selected

Network type typically should be "GSM\WCDMA PREFERRED"

Still not working?

The device will perform a scan which could take up to 2 minutes. You'll be presented with a list of available networks. Choose Koodo or Telus from this list.Note: Doing this disables international roaming. Should you ever want to roam in the future you'll need to change this setting back to automatic

If your device still isn't working, check and be sure your bill is paid up and then give Tech support a call. It's free.

You can reach Customer Service at 1-866-99-KOODO (1-866-995-6636) or 647-788-4337.
Hours of Operation
Monday - Friday: 10am - 9pm
Saturday: 9am - 7pm
Sunday: 9am - 7pm
Photo of MD


  • 1,280 Points 1k badge 2x thumb
There are 2 locks for the new(er) Sammy devices: region lock and provider lock. Maybe the unlock code changed your region.
Weird, as I thought the Canadian Samsung phones are NOT region locked, unlike some of the US ones.

This conversation is no longer open for comments or replies.