Roaming data not working in Mexico

  • 1
  • Question
  • Updated 2 years ago
  • Answered
I have the 30 day travel bundle for a week in Mexico.. but am not being able to access data. I have turned it on, I have restarted my phone, I have tried different networks.

It doesnt work.
All I have is the text package essentially.. so please refund the difference for a service that I can not access and use.
Photo of Janelle Hurrell

Janelle Hurrell

  • 142 Points 100 badge 2x thumb
  • frustrated

Posted 2 years ago

  • 1
Photo of Mathieu

Mathieu, Mobile Master

  • 60,828 Points 50k badge 2x thumb
Hi Janelle,

This is a community of users, not employees, we don't have access to your account here. Also, what you are paying for is basically a preferred rate for roaming, it is all based on availability of service and is the user's responsibility to verify their phones compatibility before they leave. You must also make sure that you have the needed international data roaming add-on on your account as well as data roaming turned on on your phone. 
Photo of Janelle Hurrell

Janelle Hurrell

  • 142 Points 100 badge 2x thumb
My phone is compatible... I have enabled data roaming and paid for the data addon.. thanks for your non help. I am a frequent traveller and user of many countries sims and networks, but only have had issues with Koodo as a provider of roaming services.
(Edited)
Photo of Mathieu

Mathieu, Mobile Master

  • 60,828 Points 50k badge 2x thumb
Except that Koodo is not the one providing the network coverage, it's the local providers that you are connecting to. Koodo has no say whatsoever in the Networks in Mexico. 
Photo of Bernard

Bernard, Official Rep

  • 75,548 Points 50k badge 2x thumb
@ Janelle Can you pls try turning airplane mode on then off? Let me know if that helped.
Photo of Janelle Hurrell

Janelle Hurrell

  • 142 Points 100 badge 2x thumb
That did thanks Bernard. Why would that have worked?
Photo of Bernard

Bernard, Official Rep

  • 75,526 Points 50k badge 2x thumb
Technically, at first, I had to add "international data roaming", a zero dollar feature to your account. You already had 'voice 'roaming' so that would have worked. The airplane mode just refreshed settings on you phone/account. Enjoy the rest of your trip!

This conversation is no longer open for comments or replies.