Received message saying I'm in USA. I am not but in Niagara Falls Canada. How to stop international roaming fees?

  • 2
  • Question
  • Updated 5 months ago
  • Answered
Received message saying I'm in USA. I am not but in Niagara Falls Canada. How to stop international roaming fees?
Photo of pherman

pherman

  • 270 Points 250 badge 2x thumb

Posted 1 year ago

  • 2
Photo of Allan

Allan, Mobile Master

  • 56,956 Points 50k badge 2x thumb
You can choose Koodo as your carrier instead of allowing your phone to automatically choose the carrier based on what signal is strongest. If you let us know what kind of phone you have we can give you instructions on how to set this.
(Edited)
Photo of pherman

pherman

  • 270 Points 250 badge 2x thumb
Thanks, done. Just don't want Koodo to charge international roaming fees.
Photo of Amanda Traviss

Amanda Traviss

  • 60 Points
I am visiting Niagara, Canada and receiving those texts as well and worried about roaming charges. I have a Samsung Note 3 with Koodo and can't seem to choose carriers as you suggested? Any help would be greatly appreciated.
(Edited)
Photo of Allan

Allan, Mobile Master

  • 56,956 Points 50k badge 2x thumb
Whats happening? Can you not choose one, cant find where to choose one?
(Edited)
Photo of Robert

Robert, Mobile Master

  • 103,858 Points 100k badge 2x thumb
It's Settings > Carrier > Turn Off automatic and choose from the list.
Photo of Ivan

Ivan, Mobile Master

  • 96,382 Points 50k badge 2x thumb
Another way is to simply disable roaming in your phone's settings (both for voice and for data).
Photo of David

David, Mobile Master

  • 88,376 Points 50k badge 2x thumb
Except there is no setting to disable voice roaming on an iPhone. There is the option for data, but not voice. Robert's suggestion is most straight-forward option.
Photo of Daniel

Daniel, Employee

  • 5,712 Points 5k badge 2x thumb
Hi pherman! If you see accidental roaming charges on your next bill, just let us know and we'll fix that for you :) 
Photo of Brianne Pockett

Brianne Pockett

  • 92 Points 75 badge 2x thumb
I'm experiencing the same thing as well in Niagara Falls Canada . I went on to carrier and turned it off and selected Koodo. Hopefully no extra charges will be applied! :)
Photo of Allan

Allan, Mobile Master

  • 56,726 Points 50k badge 2x thumb
You can view your usage for this month and see if any extra charges have been applied. As well, remember that if you go travelling and want to use your phone outside of Koodo's network youll have to change this back.
Photo of pherman

pherman

  • 270 Points 250 badge 2x thumb
Hi Daniel, just checked my present usage and there is a surprise data charge on March 12 for $5. That's the evening we arrived in Niagara Falls Canada and were at the hotel.
Photo of David

David, Mobile Master

  • 89,034 Points 50k badge 2x thumb
Data charge or texting charge?
In either case you'll need to contact Koodo more directly for an adjustment of your bill. See the 'Contact Us' section at the bottom of the page.
Photo of Jan Hope

Jan Hope

  • 4,356 Points 4k badge 2x thumb
Coming from a fully prepaid plan I have never had to worry about any roaming or voice accidental fees.

I think it becomes inconvenient to treat your phone like something that can cause, without any reason, some extra charges. You can easily lose peace of mind over something that should give you a pleasure, instead.

All this changes in the set up of your  phone can cause some headache for less tech savvy folks.

It is a well known problem for visitors and users that live in this area. Koodo have to find better solution for that problem.
Photo of pherman

pherman

  • 270 Points 250 badge 2x thumb
Thank you, I will keep an eye out for the next bill.
Photo of Kathleen Keane

Kathleen Keane

  • 164 Points 100 badge 2x thumb
I have searched through all my phone settings to find a place to disable roaming or manually select the carrier, but I got a welcome to USA text this afternoon so I am guessing I will get a roaming charges. I am staying in Niagara and have not been to the USA. I have a Samsung J3. Can anyone tell me how to fix this. My alternative is to turn my phone off till I go home. Thanks. Kathleen
Photo of Jan Hope

Jan Hope

  • 4,356 Points 4k badge 2x thumb
Hi Kathleen,

This is a pretty old topic. I would say as old as Koodo itself. Don't worry about roaming charges. Call Koodo and if you explain properly your problem they are going to wave your roaming charge. Living in Niagara, on post paid plan, can bring sometimes a lot of head ache. Probably the best option is either set properly your phone or switch to fully post paid provider like Public Mobile.
Photo of pherman

pherman

  • 270 Points 250 badge 2x thumb
What phone are u using? IF u use an iPhone go to settings and look for Carrier there you can see what carriers are available and make sure you’re not on automatic. Select Koodo. And this will not happen. As Jan Hope says, Koodo is very good on reversing charges. Went through this also last year. No issues.
Photo of Jan Hope

Jan Hope

  • 4,356 Points 4k badge 2x thumb
@pherman

She has Samsung J3. You go to Mobile Networks and then to Network Operators. When you press on Network Operators it should scan automatically for available Networks. Choose  Koodo manually.
Photo of Kathleen Keane

Kathleen Keane

  • 164 Points 100 badge 2x thumb
Thanks for trying to help. I had already gone to that section and unchecked the roaming but there was no option to deselect the autoscan. Each time I looked Koodo was set, but at some point it must have switched. My husband received a text as well and he didn't even leave the hotel. I can see that Jan Hope seems to think I am being stupid about this but I even got my teenage son to check and there was no where else that we could see to change the settings. I will call Koodo about any charges that have been added and I will ask the store I bought the phone from about the settings. I am back home know and can deal with it. Thanks again for trying to help and responding in a kind and patient way.
Photo of Kathleen Keane

Kathleen Keane

  • 164 Points 100 badge 2x thumb
Samsung J3. I thought I had changed the settings but I guess it didn't work. I tried to call Koodo this afternoon but gave up after almost an hour. I don't live in Niagara I am in a hotel.
Photo of Kathleen Keane

Kathleen Keane

  • 164 Points 100 badge 2x thumb
I was hoping someone would be able to tell me how to set it properly. I will call them again when I get home. Hopefully I will be able to get through eventually.
Photo of Jan Hope

Jan Hope

  • 4,356 Points 4k badge 2x thumb
@Kathleen

Someone has already told you how to se it properly. Look up to earlier responses.
Photo of Kathleen Keane

Kathleen Keane

  • 164 Points 100 badge 2x thumb
Please be kind and patient in your responses. I was asking for help because I didn't know. Perhaps you didn't mean it but your responses came across as snippy.
Photo of Jan Hope

Jan Hope

  • 4,356 Points 4k badge 2x thumb
Hi Kathleen,

You can ask for help as much as you want. There are no bad questions on this forum. Unfortunately kindness and patience you can only express through emotions and face to face and not responses. Believe me, you cannot find someone more patient and kind than me.

At least I have learned new English Canadian word "snippy" LOL
Photo of Jan Hope

Jan Hope

  • 4,356 Points 4k badge 2x thumb
@Kathleen

And by the way, I have never thought about anyone coming to this forum for help as being stupid including you Kathleen. We had simply miscommunication.